diff mbox series

[bug#65749] gnu: libndp: Fix cross-compile.

Message ID 44232e5ddaa22c46b77284dfe141d3d5181e9735.1693840715.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#65749] gnu: libndp: Fix cross-compile. | expand

Commit Message

Zheng Junjie Sept. 4, 2023, 3:18 p.m. UTC
* gnu/packages/networking.scm (libndp)
[native-inputs]: When cross-compile add pkg-config, libtool, gettext-minimal,
autoconf, automake.
[arguments]: When cross-compile, add phase to fix rpl_malloc undefined references.
---
 gnu/packages/networking.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)


base-commit: bedcdf0fb5ac035f696790827679406c7146396c

Comments

Maxim Cournoyer Sept. 6, 2023, 3:41 a.m. UTC | #1
Hi,

Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

> * gnu/packages/networking.scm (libndp)
> [native-inputs]: When cross-compile add pkg-config, libtool, gettext-minimal,
> autoconf, automake.
> [arguments]: When cross-compile, add phase to fix rpl_malloc undefined references.

Installed, thank you.
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f4ecd85009..865da14d9b 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1474,6 +1474,26 @@  (define-public libndp
                (base32
                 "0ay0n0d85254zdmv8znmn399gfiqpk6ga0jwdwa7ylpbw9pbdzw8"))))
     (build-system gnu-build-system)
+    (native-inputs
+     (if (%current-target-system)
+         (list pkg-config
+               libtool
+               gettext-minimal
+               autoconf automake)
+         '()))
+    (arguments
+     (if (%current-target-system)
+         (list #:phases
+               #~(modify-phases %standard-phases
+                   ;; AC_FUNC_MALLOC and AC_FUNC_REALLOC usually unneeded
+                   ;; see https://lists.gnu.org/archive/html/autoconf/2003-02/msg00017.html
+                   (add-after 'unpack 'fix-rpl_malloc
+                     (lambda _
+                       (substitute* "configure.ac"
+                         (("AC_FUNC_MALLOC") ""))
+                       ;; let bootstrap phase run.
+                       (delete-file "./configure")))))
+         '()))
     (home-page "https://libndp.org/")
     (synopsis "Library for Neighbor Discovery Protocol")
     (description