diff mbox series

[bug#62873,gnome-team,6/6] gnu: gst-plugins-base: Fix build.

Message ID 43da6ec9e3cd102cdd1403d144009ba15b2d6769.camel@gmail.com
State New
Headers show
Series Merge master into gnome-team | expand

Commit Message

Liliana Marie Prikler April 16, 2023, 5:47 a.m. UTC
* gnu/packages/patches/gst-plugins-base-fix-broken-test.patch: New file.
* gnu/packages/gstreamer.scm (gst-plugins-base)[patches]: Use it here.
* gnu/local.mk (dist_patch_DATA): Register it here.
---
As a follow-up to the master merge, the good, bad, and ugly plugins
as well as gst-editing-services build with this simple trick.

 gnu/local.mk                                  |  1 +
 gnu/packages/gstreamer.scm                    |  3 ++-
 .../gst-plugins-base-fix-broken-test.patch    | 22 +++++++++++++++++++
 3 files changed, 25 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/gst-plugins-base-fix-broken-test.patch

Comments

Maxim Cournoyer April 18, 2023, 4:42 p.m. UTC | #1
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/patches/gst-plugins-base-fix-broken-test.patch: New file.
> * gnu/packages/gstreamer.scm (gst-plugins-base)[patches]: Use it here.
> * gnu/local.mk (dist_patch_DATA): Register it here.
> ---
> As a follow-up to the master merge, the good, bad, and ugly plugins
> as well as gst-editing-services build with this simple trick.
>
>  gnu/local.mk                                  |  1 +
>  gnu/packages/gstreamer.scm                    |  3 ++-
>  .../gst-plugins-base-fix-broken-test.patch    | 22 +++++++++++++++++++
>  3 files changed, 25 insertions(+), 1 deletion(-)
>  create mode 100644 gnu/packages/patches/gst-plugins-base-fix-broken-test.patch
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 72b73761d8..1d7c5696f5 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -1303,6 +1303,7 @@ dist_patch_DATA =						\
>    %D%/packages/patches/guile-present-coding.patch		\
>    %D%/packages/patches/guile-rsvg-pkgconfig.patch		\
>    %D%/packages/patches/guile-emacs-fix-configure.patch		\
> +  %D%/packages/patches/gst-plugins-base-fix-broken-test.patch		\
>    %D%/packages/patches/gtk2-fix-builder-test.patch		\
>    %D%/packages/patches/gtk2-harden-list-store.patch		\
>    %D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch	\

I'm surprised this is needed, I hadn't encountered the failure.  Perhaps
it's a non-deterministic test?

Anyway, thank you!  The series LGTM.
Liliana Marie Prikler April 18, 2023, 6:30 p.m. UTC | #2
Am Dienstag, dem 18.04.2023 um 12:42 -0400 schrieb Maxim Cournoyer:
> Hi Liliana,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > * gnu/packages/patches/gst-plugins-base-fix-broken-test.patch: New
> > file.
> > * gnu/packages/gstreamer.scm (gst-plugins-base)[patches]: Use it
> > here.
> > * gnu/local.mk (dist_patch_DATA): Register it here.
> > ---
> > As a follow-up to the master merge, the good, bad, and ugly plugins
> > as well as gst-editing-services build with this simple trick.
> > 
> >  gnu/local.mk                                  |  1 +
> >  gnu/packages/gstreamer.scm                    |  3 ++-
> >  .../gst-plugins-base-fix-broken-test.patch    | 22
> > +++++++++++++++++++
> >  3 files changed, 25 insertions(+), 1 deletion(-)
> >  create mode 100644 gnu/packages/patches/gst-plugins-base-fix-
> > broken-test.patch
> > 
> > diff --git a/gnu/local.mk b/gnu/local.mk
> > index 72b73761d8..1d7c5696f5 100644
> > --- a/gnu/local.mk
> > +++ b/gnu/local.mk
> > @@ -1303,6 +1303,7 @@ dist_patch_DATA
> > =                                         \
> >    %D%/packages/patches/guile-present-coding.patch              \
> >    %D%/packages/patches/guile-rsvg-pkgconfig.patch              \
> >    %D%/packages/patches/guile-emacs-fix-configure.patch         \
> > +  %D%/packages/patches/gst-plugins-base-fix-broken-
> > test.patch          \
> >    %D%/packages/patches/gtk2-fix-builder-test.patch             \
> >    %D%/packages/patches/gtk2-harden-list-store.patch            \
> >    %D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch       \
> 
> I'm surprised this is needed, I hadn't encountered the failure. 
> Perhaps it's a non-deterministic test?
It is a deterministic failure as far as I see.  Did you test with glib
2.73 (current master) or 2.76 (gnome-team)?

Cheers
Maxim Cournoyer April 20, 2023, 1:41 a.m. UTC | #3
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Dienstag, dem 18.04.2023 um 12:42 -0400 schrieb Maxim Cournoyer:
>> Hi Liliana,
>> 
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>> 
>> > * gnu/packages/patches/gst-plugins-base-fix-broken-test.patch: New
>> > file.
>> > * gnu/packages/gstreamer.scm (gst-plugins-base)[patches]: Use it
>> > here.
>> > * gnu/local.mk (dist_patch_DATA): Register it here.
>> > ---
>> > As a follow-up to the master merge, the good, bad, and ugly plugins
>> > as well as gst-editing-services build with this simple trick.
>> > 
>> >  gnu/local.mk                                  |  1 +
>> >  gnu/packages/gstreamer.scm                    |  3 ++-
>> >  .../gst-plugins-base-fix-broken-test.patch    | 22
>> > +++++++++++++++++++
>> >  3 files changed, 25 insertions(+), 1 deletion(-)
>> >  create mode 100644 gnu/packages/patches/gst-plugins-base-fix-
>> > broken-test.patch
>> > 
>> > diff --git a/gnu/local.mk b/gnu/local.mk
>> > index 72b73761d8..1d7c5696f5 100644
>> > --- a/gnu/local.mk
>> > +++ b/gnu/local.mk
>> > @@ -1303,6 +1303,7 @@ dist_patch_DATA
>> > =                                         \
>> >    %D%/packages/patches/guile-present-coding.patch              \
>> >    %D%/packages/patches/guile-rsvg-pkgconfig.patch              \
>> >    %D%/packages/patches/guile-emacs-fix-configure.patch         \
>> > +  %D%/packages/patches/gst-plugins-base-fix-broken-
>> > test.patch          \
>> >    %D%/packages/patches/gtk2-fix-builder-test.patch             \
>> >    %D%/packages/patches/gtk2-harden-list-store.patch            \
>> >    %D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch       \
>> 
>> I'm surprised this is needed, I hadn't encountered the failure. 
>> Perhaps it's a non-deterministic test?
> It is a deterministic failure as far as I see.  Did you test with glib
> 2.73 (current master) or 2.76 (gnome-team)?

It was on staging, so 2.73 I think.

-- 
Thanks,
Maxim
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 72b73761d8..1d7c5696f5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1303,6 +1303,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/guile-present-coding.patch		\
   %D%/packages/patches/guile-rsvg-pkgconfig.patch		\
   %D%/packages/patches/guile-emacs-fix-configure.patch		\
+  %D%/packages/patches/gst-plugins-base-fix-broken-test.patch		\
   %D%/packages/patches/gtk2-fix-builder-test.patch		\
   %D%/packages/patches/gtk2-harden-list-store.patch		\
   %D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch	\
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 0d051438e3..486ebe6dcd 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -554,7 +554,8 @@  (define-public gst-plugins-base
                           name "-" version ".tar.xz"))
       (sha256
        (base32
-        "0jcxcx4mgfjvfb3ixibwhx8j330mq3ap469w7hapm6z79q614rgb"))))
+        "0jcxcx4mgfjvfb3ixibwhx8j330mq3ap469w7hapm6z79q614rgb"))
+      (patches (search-patches "gst-plugins-base-fix-broken-test.patch"))))
     (build-system meson-build-system)
     (propagated-inputs
      (list glib                     ;required by gstreamer-sdp-1.0.pc
diff --git a/gnu/packages/patches/gst-plugins-base-fix-broken-test.patch b/gnu/packages/patches/gst-plugins-base-fix-broken-test.patch
new file mode 100644
index 0000000000..2785983d8d
--- /dev/null
+++ b/gnu/packages/patches/gst-plugins-base-fix-broken-test.patch
@@ -0,0 +1,22 @@ 
+Index: gst-plugins-base-1.22.1/tests/check/libs/allocators.c
+===================================================================
+--- gst-plugins-base-1.22.1.orig/tests/check/libs/allocators.c
++++ gst-plugins-base-1.22.1/tests/check/libs/allocators.c
+@@ -80,7 +80,7 @@ GST_START_TEST (test_fdmem)
+ 
+   alloc = gst_fd_allocator_new ();
+   fail_unless (alloc);
+-  mem = gst_fd_allocator_alloc (alloc, fd, 10, GST_FD_MEMORY_FLAG_KEEP_MAPPED);
++  mem = gst_fd_allocator_alloc (alloc, fd, 10, GST_FD_MEMORY_FLAG_KEEP_MAPPED | GST_FD_MEMORY_FLAG_DONT_CLOSE);
+ 
+   fail_unless (gst_memory_map (mem, &info, GST_MAP_READ));
+   fail_unless (info.data[5] == '5');
+@@ -95,7 +95,7 @@ GST_START_TEST (test_fdmem)
+   gst_memory_unmap (mem, &info);
+ 
+   gst_memory_unref (mem);
+-  fail_unless (g_close (fd, NULL) == 0);
++  fail_unless (g_close (fd, NULL));
+   gst_object_unref (alloc);
+ }
+