diff mbox series

[bug#36824] gnu: Add oshu.

Message ID 43d8ddacca5f945e71f43c146197aca584ec950c.camel@student.tugraz.at
State Accepted
Headers show
Series [bug#36824] gnu: Add oshu. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler Feb. 20, 2021, 7:07 p.m. UTC
Hello everyone,

I'm reviving this old patch and hopefully address most of the issues
raised for the old one while also sneaking in a version upgrade.

Regards,
Leo
diff mbox series

Patch

From 6c7a1d039e2678147fe1d4f7be7e59ef58a2d661 Mon Sep 17 00:00:00 2001
From: Dan Frumin <dfrumin@cs.ru.nl>
Date: Sat, 27 Jul 2019 20:18:22 +0200
Subject: [PATCH] gnu: Add oshu.

* gnu/packages/games.scm (oshu): New variable.

Co-authored-by: Leo Prikler <leo.prikler@student.tugraz.at>
---
 gnu/packages/games.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6726cef303..0ea972419c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8413,6 +8413,45 @@  to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
     (home-page "https://www.stepmania.com")
     (license license:expat)))
 
+(define-public oshu
+  (package
+    (name "oshu")
+    (version "2.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/fmang/oshu")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1g598incc6zlls876slgwqblwiwiszkmqa4xpzw0z7mbjmmzsizz"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("sdl2" ,sdl2)
+       ("sdl2-image" ,sdl2-image)
+       ("ffmpeg" ,ffmpeg)
+       ("cairo" ,cairo)
+       ("pango" ,pango)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'pre-check
+           ;; `make test' doesn't actually build the test executable
+           (lambda _ (invoke "make" "zerotokei"))))))
+    (home-page "https://github.com/fmang/oshu/")
+    (synopsis "Rhythm game in which you click on circles")
+    (description "@dfn{oshu!} is a minimalist variant of the osu! rhythm game,
+which is played by pressing buttons and following along sliders as they appear
+on screen.  Its aim is to be able to play any beatmap even on low-end hardware.
+
+This package provides the core application, but no beatmaps.  You need to
+download and unpack them separately.")
+    (license license:gpl3+)))
+
 (define-public btanks
   (package
     (name "btanks")
-- 
2.30.1