diff mbox series

[bug#65313,v2] * gnu/packages/erlang.scm (erlang-lfe): New variable.

Message ID 43d67dfca58a7dd9384f5c566a50f3f647ce23ab.1694033873.git.t1m@phrogstar.de
State New
Headers show
Series [bug#65313,v2] * gnu/packages/erlang.scm (erlang-lfe): New variable. | expand

Commit Message

Tim Johann Sept. 6, 2023, 8:57 p.m. UTC
---
 gnu/packages/erlang.scm | 72 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 72 insertions(+)


base-commit: 65dcfb3f3865d08467da747041263fd22460d393

Comments

Maxim Cournoyer Sept. 7, 2023, 2:32 a.m. UTC | #1
Hi Tim,

Tim Johann <t1m@phrogstar.de> writes:

> ---
>  gnu/packages/erlang.scm | 72 +++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 72 insertions(+)

I've adjusted the commit message like so:

--8<---------------cut here---------------start------------->8---
    gnu: Add erlang-lfe.
    
    * gnu/packages/erlang.scm (erlang-lfe): New variable.
--8<---------------cut here---------------end--------------->8---

Made other small cosmetic changes such as moving the #:make-flags above
the #:phases, the inputs after the build arguments, added a copyright
line with your name, and installed it with commit 5ef28595e.

Thank you for your contribution!
diff mbox series

Patch

diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index a7f161647b..b0ad4ea2a7 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -27,6 +27,7 @@ 
 
 (define-module (gnu packages erlang)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix gexp)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system emacs)
   #:use-module (guix build-system rebar)
@@ -738,3 +739,74 @@  (define-public rebar3-proper
     (description "This plugin allows running PropEr test suites from within
 rebar3.")
     (license license:bsd-3)))
+
+(define-public erlang-lfe
+  (package
+    (name "erlang-lfe")
+    (version "2.1.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/lfe/lfe")
+                    (commit "v2.1.2")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "180hz1p2v3vb6yyzcfwircmljlnd86ln8z80lzy3mwlyrcxblvxy"))))
+    (build-system gnu-build-system)
+    (native-inputs (list rebar3 rebar3-proper erlang-proper))
+    (propagated-inputs (list erlang))
+    (arguments
+     (list
+      #:modules '((ice-9 ftw)
+                  (srfi srfi-26)
+                  (guix build gnu-build-system)
+                  (guix build utils))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)
+          ;; The following is inspired by rebar-build-system.scm
+          (add-before 'check 'erlang-depends
+            (lambda* (#:key inputs #:allow-other-keys)
+              (define input-directories
+                (list #$(this-package-native-input "rebar3-proper")
+                      #$(this-package-native-input "erlang-proper")))
+              (mkdir-p "_checkouts")
+              (for-each
+               (lambda (input-dir)
+                 (let ((elibdir (string-append input-dir "/lib/erlang/lib")))
+                   (when (directory-exists? elibdir)
+                     (for-each
+                      (lambda (dirname)
+                        (let ((src (string-append elibdir "/" dirname))
+                              (dest (string-append "_checkouts/" dirname)))
+                          (when (not (file-exists? dest))
+                            ;; symlinking will not work, since rebar3 will
+                            ;; try to overwrite the _build directory several
+                            ;; times with the contents of _checkout, so we
+                            ;; copy the directory tree to _checkout and make
+                            ;; it writeable.
+                            (copy-recursively src dest #:follow-symlinks? #t)
+                            (for-each (cut chmod <> #o777) (find-files dest)))))
+                      (scandir elibdir (lambda (file)
+                                         (and (not (member file '("." "..")))
+                                              (file-is-directory?
+                                               (string-append elibdir
+                                                              "/"
+                                                              file)))))))))
+               input-directories)))
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (begin
+                  (setenv "REBAR_CACHE_DIR" "/tmp")
+                  (invoke "make" "-j" "tests"))))))
+      #:make-flags
+      #~(list (string-append "PREFIX=" #$output) "CC=gcc")))
+    (home-page "https://github.com/lfe/lfe")
+    (synopsis "Lisp Flavoured Erlang")
+    (description
+     "LFE, Lisp Flavoured Erlang, is a lisp syntax front-end to the Erlang
+compiler.  Code produced with it is compatible with \"normal\" Erlang
+ code.  An LFE evaluator and shell is also included.")
+    (license license:asl2.0)))