[bug#75438] add hyprsysteminfo

Message ID 43d64438c8c31600e392534d9373ff30dbf3bb05.1736349916.git.squishypinkelephant@gmail.com
State New
Headers
Series [bug#75438] add hyprsysteminfo |

Commit Message

squishypinkelephant Jan. 8, 2025, 3:49 p.m. UTC
  Change-Id: I832773e7104a1f6979ef8ab3fcd306170c2c90fc
---
 gnu/packages/xdisorg.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: d419052a5ae7b2f06bcf9269cb5bf298b81c9072
  

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 8c62c25bc0..17ec74ca63 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3815,6 +3815,35 @@  (define-public hyprpolkitagent
     "A polkit authentication agent written in QT/QML")
     (license license:bsd-3)))
 
+(define-public hyprsysteminfo
+  (package
+    (name "hyprsysteminfo")
+    (version "0.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/hyprwm/hyprsysteminfo")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+              (base32
+                "1gr7v5jhyr331yp2b28f81lvbn72zpqjfksxv3w8vs5srjf5bz78"))))
+    (build-system cmake-build-system)
+    (arguments
+      `(#:tests? #f)) ;No tests
+    (native-inputs (list gcc-13 pkg-config))
+    (inputs
+      (list bash-minimal
+        hyprutils
+        hyprland
+        qtbase
+        qtdeclarative))
+    (home-page "https://github.com/hyprwm/hyprsysteminfo")
+    (synopsis "Hyprland system info")
+    (description
+    "A tiny qt6/qml application to display information about the running system")
+    (license license:bsd-3)))
+
 (define-public jumpapp
   (package
     (name "jumpapp")