diff mbox series

[bug#62228,v4,3/3] gnu: Add sgt-puzzles.

Message ID 4389dc229183f814581dd5ca87c12157ac81c744.1710228453.git.sarg@sarg.org.ru
State New
Headers show
Series [bug#62228,v4,1/3] gnu: Prefix licenses in documentation.scm | expand

Commit Message

Sergey Trofimov March 12, 2024, 7:28 a.m. UTC
* gnu/packages/games.scm (sgt-puzzles): New variable.
---
 gnu/packages/games.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Comments

Liliana Marie Prikler March 12, 2024, 7:50 a.m. UTC | #1
Am Dienstag, dem 12.03.2024 um 08:28 +0100 schrieb Sergey Trofimov:
> * gnu/packages/games.scm (sgt-puzzles): New variable.
> ---
>  gnu/packages/games.scm | 34 ++++++++++++++++++++++++++++++++++
>  1 file changed, 34 insertions(+)
> 
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 9ff08e5e74..94aa9e9140 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -938,6 +938,40 @@ (define-public rogue
>      (home-page "https://github.com/Davidslv/rogue")
>      (license license:bsd-3)))
>  
> +(define-public sgt-puzzles
> +  (package
> +    (name "sgt-puzzles")
> +    (version "20240302.80aac31")
It is still unclear where this version string comes from.  See section
22.5.3 Version Numbers in the manual for the correct layout.
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url
> "https://git.tartarus.org/simon/puzzles.git")
> +                    (commit
> "80aac3104096aee4057b675c53ece8e60793aa90")))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +               
> "0z4clv0xi98q28riz323ppn165cm62gj1c6h3xdd2sym4v8gy65z"))))
> +    (build-system cmake-build-system)
> +    (arguments
> +     (list #:tests? #f ;No tests.
> +           #:configure-flags #~(list "-DNAME_PREFIX=sgt-")
> +           #:phases #~(modify-phases %standard-phases
> +                        (add-after 'unpack 'set-xdg-open-path
> +                          (lambda _
> +                            (substitute* "gtk.c"
> +                              (("(#define HELP_BROWSER_PATH ).+" all
> define)
> +                               (string-append define "\""
> +                                              #$(this-package-input
> +                                                 "xdg-utils")
> +                                              "/bin/xdg-
> open\"\n"))))))))
Use search-input-file instead.  You might also want to dedent this
whole thing a little to save some horizontal real-estate and fit one-
liners into one line, actually.
> +    (inputs (list gtk+ xdg-utils))
> +    (native-inputs (list pkg-config perl imagemagick halibut))
> +    (home-page
> "https://www.chiark.greenend.org.uk/~sgtatham/puzzles/")
> +    (synopsis "Simon Tatham's portable puzzle collection")
> +    (description
> +     "Simon Tatham's Portable Puzzle Collection contains a number of
> +popular puzzle games for one player.")
> +    (license license:expat)))
Cheers
Sergey Trofimov March 12, 2024, 8:11 a.m. UTC | #2
Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> writes:

> Am Dienstag, dem 12.03.2024 um 08:28 +0100 schrieb Sergey 
> Trofimov:
>> * gnu/packages/games.scm (sgt-puzzles): New variable.
>> ---
>>  gnu/packages/games.scm | 34 ++++++++++++++++++++++++++++++++++
>>  1 file changed, 34 insertions(+)
>>
>> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
>> index 9ff08e5e74..94aa9e9140 100644
>> --- a/gnu/packages/games.scm
>> +++ b/gnu/packages/games.scm
>> @@ -938,6 +938,40 @@ (define-public rogue
>>      (home-page "https://github.com/Davidslv/rogue")
>>      (license license:bsd-3)))
>>  
>> +(define-public sgt-puzzles
>> +  (package
>> +    (name "sgt-puzzles")
>> +    (version "20240302.80aac31")
> It is still unclear where this version string comes from.  See 
> section
> 22.5.3 Version Numbers in the manual for the correct layout.

This is the versioning scheme used by the author. It's a build 
date and the git commit hash.
It seems compatible with the way prescribed by the guix manual.
Though I'll adapt it to use git-version instead.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9ff08e5e74..94aa9e9140 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -938,6 +938,40 @@  (define-public rogue
     (home-page "https://github.com/Davidslv/rogue")
     (license license:bsd-3)))
 
+(define-public sgt-puzzles
+  (package
+    (name "sgt-puzzles")
+    (version "20240302.80aac31")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.tartarus.org/simon/puzzles.git")
+                    (commit "80aac3104096aee4057b675c53ece8e60793aa90")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0z4clv0xi98q28riz323ppn165cm62gj1c6h3xdd2sym4v8gy65z"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:tests? #f ;No tests.
+           #:configure-flags #~(list "-DNAME_PREFIX=sgt-")
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'set-xdg-open-path
+                          (lambda _
+                            (substitute* "gtk.c"
+                              (("(#define HELP_BROWSER_PATH ).+" all define)
+                               (string-append define "\""
+                                              #$(this-package-input
+                                                 "xdg-utils")
+                                              "/bin/xdg-open\"\n"))))))))
+    (inputs (list gtk+ xdg-utils))
+    (native-inputs (list pkg-config perl imagemagick halibut))
+    (home-page "https://www.chiark.greenend.org.uk/~sgtatham/puzzles/")
+    (synopsis "Simon Tatham's portable puzzle collection")
+    (description
+     "Simon Tatham's Portable Puzzle Collection contains a number of
+popular puzzle games for one player.")
+    (license license:expat)))
 
 (define-public bzflag
   (package