From b14de1521e6633fc15d35d34b9eb7b2a23f05aee Mon Sep 17 00:00:00 2001
From: Naga Malleswari <nagamalli@riseup.net>
Date: Sat, 4 Apr 2020 18:40:58 +0530
Subject: [PATCH] gnu: Add r-asd.
* gnu/packages/cran.scm (r-asd): New variable.
---
gnu/packages/cran.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
@@ -20,6 +20,7 @@
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2020 Todor Kondić <tk.code@protonmail.com>
;;; Copyright © 2020 Danjela Lura <danielaluraa@gmail.com>
+;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21054,3 +21055,25 @@ where tcltk is present are supported.")
with R, controlling a remote R session (the server) from a local one (the
client).")
(license license:bsd-2)))
+
+(define-public r-asd
+ (package
+ (name "r-asd")
+ (version "2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "asd" version))
+ (sha256
+ (base32
+ "0p3r4qjam3sl3rpcilb0pgx4xx3ly71xqnvkv31vzjs885lgxz4l"))))
+ (properties `((upstream-name . "asd")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mvtnorm" ,r-mvtnorm)))
+ (home-page "https://cran.r-project.org/web/packages/asd")
+ (synopsis "Simulations for Adaptive Seamless Designs")
+ (description
+ "Package runs simulations for adaptive seamless designs with and without
+early outcomes for treatment selection and subpopulation type designs.")
+ (license license:gpl3)))
--
2.25.1