diff mbox series

[bug#64137,v3,5/7] gnu: Add tl-optional.

Message ID 4285ed9466bf8588533b2e83290ab83a2ca3133d.1687687428.git.david.elsing@posteo.net
State New
Headers show
Series [bug#64137,v3,1/7] gnu: Add mpark-variant. | expand

Commit Message

David Elsing June 25, 2023, 10:03 a.m. UTC
* gnu/packages/cpp.scm (tl-optional): New variable.
---
 gnu/packages/cpp.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index efce934e6d..7e89b9d80a 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2696,3 +2696,36 @@  (define-public tsl-ordered-map
 efficient ordered insertions and lookup, while sacrifing performance for
 ordered erase operations.")
     (license license:expat)))
+
+(define-public tl-optional
+  (package
+    (name "tl-optional")
+    (version "1.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/TartanLlama/optional")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0qkjplmhilbi1iqxx3pz0grcx5355ymk6wwd4h4309mk156xgx2q"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-cmake-test
+            (lambda _
+              (substitute* "CMakeLists.txt"
+                (("FetchContent_Declare.*") "")
+                ((".*http.*catchorg/Catch2.*") "")
+                (("FetchContent_MakeAvailable\\(Catch2\\)")
+                 "find_package(Catch2 REQUIRED)")))))))
+    (native-inputs (list catch2))
+    (home-page "https://github.com/TartanLlama/optional")
+    (synopsis "Implementation of std::optional with extensions for C++11/14/17")
+    (description "tl-optional provides a single-header implementation of the
+C++17 std::optional for C++11/14/17.  It includes functional-style extensions
+and support for references.")
+    (license license:cc0)))