[bug#67755,v6,2/8] gnu: Add plutovg.

Message ID 427e70e62c0bcb30b5f140e971842624a2e25f9d.1742403600.git.liliana.prikler@gmail.com
State New
Headers
Series gnu: Add imhex |

Commit Message

Liliana Marie Prikler March 19, 2025, 5 p.m. UTC
  * gnu/packages/cpp.scm (plutovg): New variable.

Change-Id: I23d615af1545b79f07a64902c472e6a2e081af5a
---
 gnu/packages/cpp.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
  

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 9673d607db1..d4cf4a68ac8 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -615,6 +615,28 @@  (define-public rct
       (license (list license:expat        ; cJSON
                      license:bsd-4)))))   ; everything else (LICENSE.txt)
 
+(define-public plutovg
+  (package
+    (name "plutovg")
+    (version "0.0.13")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sammycage/plutovg")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0y2w0qhs89bnh440z1xj65vg4c71rlwinxgs3p8bvh2fmbi7lqff"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")
+       #:tests? #f)) ;No tests.
+    (home-page "https://github.com/sammycage/plutovg")
+    (synopsis "Tiny 2D vector graphics library in C")
+    (description "PlutoVG is a standalone 2D vector graphics library in C.")
+    (license license:expat)))
+
 (define-public pystring
   (package
     (name "pystring")