diff mbox series

[bug#74223,05/11] gnu: Add hyprlang.

Message ID 424ba09ef7f9e55308df79b7569c707587e8ffe5.1730877074.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add hyprland. | expand

Commit Message

Hilton Chain Nov. 6, 2024, 7:36 a.m. UTC
* gnu/packages/wm.scm (hyprlang): New variable.

Change-Id: Ie585412bd26bff2c5949ed3aef15c37f6958dc0b
---
 gnu/packages/cpp.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ddc9d7c136..5d01c8afb6 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -664,6 +664,29 @@  (define-public google-highway
 library for SIMD (Single Instruction, Multiple Data) with runtime dispatch.")
     (license license:asl2.0)))
 
+(define-public hyprlang
+  (package
+    (name "hyprlang")
+    (version "0.5.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/hyprwm/hyprlang")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0yvfrz3hdyxzhngzhr0bgc5279ra5fv01hbfi6pdj84pz0lpaw02"))))
+    (build-system cmake-build-system)
+    (native-inputs (list gcc-13 pkg-config))
+    (inputs (list hyprutils))
+    (home-page "https://wiki.hyprland.org/Hypr-Ecosystem/hyprlang/")
+    (synopsis "Official implementation library for hypr config language")
+    (description
+     "This package provides the official implementation for hypr configuration
+language used in Hyprland.")
+    (license license:lgpl3)))
+
 (define-public hyprutils
   (package
     (name "hyprutils")