diff mbox series

[bug#62293,v2] gnu: add cyberjack-pcsc

Message ID 422b81a4-a9ca-2973-f897-5ea381b26bf3@zedat.fu-berlin.de
State New
Headers show
Series [bug#62293,v2] gnu: add cyberjack-pcsc | expand

Commit Message

Arvid Krein March 22, 2023, 2:26 p.m. UTC
Hello Bruno,

I thought a while about package naming and now think that cyberjack-pcsc 
might be a better package name. The package is not part of pcsc but 
rather contains pcsc drivers for cyberjack so I would think 
cyberjack-pcsc is more appropriate. I am not sure about this though and 
would be happy about feedback. In general this aligns better with how I 
think guix package names are chosen.

Greetings,

Arvid

* gnu/packages/security-token.scm (cyberjack-pcsc): New variable.
---
  gnu/packages/security-token.scm | 31 +++++++++++++++++++++++++++++++
  1 file changed, 31 insertions(+)

+     "This package includes the IFD driver for the cyberJack 
contactless (RFID) and contac
t USB chipcard readers.")
+    (home-page "http://www.reiner-sct.com/")
+    (license license:lgpl2.1+)))

base-commit: 4f8a13b9fbfd0efcb94ee8da46b09c6dbe84ac4b
--
2.39.2

Comments

宋文武 June 2, 2023, 11:28 a.m. UTC | #1
Arvid Krein <arvidkrein@zedat.fu-berlin.de> writes:

> Hello Bruno,
>
> I thought a while about package naming and now think that
> cyberjack-pcsc might be a better package name.

Hello, I pushed it as 'pcsc-cyberjack', as it's a driver/extension to
pcsc.  Note that Archlinux also has it:
https://aur.archlinux.org/packages/pcsc-cyberjack


Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/security-token.scm 
b/gnu/packages/security-token.scm
index 3cf585480e..11ec681cdc 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -1025,3 +1025,34 @@  (define-public cardpeek
  It also has limited support for Mifare Classic compatible cards 
(Thalys card)")
      (license license:gpl3+)
      (home-page "http://pannetrat.com/Cardpeek")))
+
+(define-public cyberjack-pcsc
+  (package
+    (name "cyberjack-pcsc")
+    (version "3.99.5final.sp15")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+ 
"https://support.reiner-sct.de/downloads/LINUX/V3.99.5_SP15/pcsc-cyberjack_3.99.5f
inal.SP15.tar.bz2")
+       (sha256
+        (base32
+ "0yj6plgb245r218v6lgdabb3422hxyrw8rrpf5b8fwah4j1w5dxc"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:configure-flags
+      #~(list (string-append "--with-usbdropdir=" #$output "/pcsc/drivers")
+              (string-append "--bindir=" #$output:tools "/bin"))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'install-tools
+            (lambda _ (invoke "make" "-C" "tools/cjflash" "install"))))))
+    (native-inputs (list pkg-config))
+    (inputs (list pcsc-lite libusb))
+    (outputs '("out" "tools"))
+    (synopsis "PC/SC driver for cyberJack chipcard readers")
+    (description