diff mbox series

[bug#69428,3/4] gnu: bspwm: Use Gexps.

Message ID 4225aa7bfa7aedaf494fdb116a5b065ca4fee5c0.1709046624.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series fix sxhkd and bspwm cross-compilation. | expand

Commit Message

Zheng Junjie Feb. 27, 2024, 3:50 p.m. UTC
* gnu/packages/wm.scm(bspwm)[arguments]: Use Gexps.

Change-Id: I47399c52c8ba9adb8ea95c2a05cc8ba4762bbca3
---
 gnu/packages/wm.scm | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index ae8213ddae..68b381fa90 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -41,7 +41,7 @@ 
 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
 ;;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
 ;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
-;;; Copyright © 2021, 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021, 2023, 2024 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2021 qblade <qblade@protonmail.com>
 ;;; Copyright © 2021 lasnesne <lasnesne@lagunposprasihopre.org>
@@ -184,13 +184,13 @@  (define-public bspwm
            xcb-util-keysyms
            xcb-util-wm))
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (delete 'configure))           ; no configure script
-       #:tests? #f                      ; no check target
-       #:make-flags
-       (list "CC=gcc"
-             (string-append "PREFIX=" %output))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure))           ; no configure script
+           #:tests? #f                      ; no check target
+           #:make-flags
+           #~(list "CC=gcc"
+                   (string-append "PREFIX=" #$output))))
     (home-page "https://github.com/baskerville/bspwm")
     (synopsis "Tiling window manager based on binary space partitioning")
     (description "bspwm is a tiling window manager that represents windows as