diff mbox series

[bug#61515] gnu: python-poppler-qt5: Remove transitive dependency on QtWebkit.

Message ID 41db8651ddc9ecb200a2e661fb9d43593a70dd3a.1676410429.git.leo@famulari.name
State New
Headers show
Series [bug#61515] gnu: python-poppler-qt5: Remove transitive dependency on QtWebkit. | expand

Commit Message

Leo Famulari Feb. 14, 2023, 9:33 p.m. UTC
This is required for <https://issues.guix.gnu.org/53289>.

* gnu/packages/pdf.scm (python-poppler-qt5)[inputs]: Replace python-pyqt with
python-pyqt-without-qtwebkit.
[arguments]: Adjust accordingly.
---
 gnu/packages/pdf.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Leo Famulari Feb. 17, 2023, 7:07 p.m. UTC | #1
I'm closing this patch because it is superseded by
<https://issues.guix.gnu.org/61536>.
diff mbox series

Patch

diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 864c23b0d2..478977d8c5 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -373,12 +373,12 @@  (define-public python-poppler-qt5
              ;; installation phase.
              ((@@ (guix build python-build-system) call-setuppy)
               "build_ext" (list (string-append "--pyqt-sip-dir="
-                                               (assoc-ref inputs "python-pyqt")
+                                               (assoc-ref inputs "python-pyqt-without-qtwebkit")
                                                "/share/sip")) #t))))))
     (native-inputs
      (list pkg-config))
     (inputs
-     (list python-sip-4 python-pyqt poppler-qt5 qtbase-5))
+     (list python-sip-4 python-pyqt-without-qtwebkit poppler-qt5 qtbase-5))
     (home-page "https://pypi.org/project/python-poppler-qt5/")
     (synopsis "Python bindings for Poppler-Qt5")
     (description