diff mbox series

[bug#74290,v3,39/51] gnu: guile-fibers: Fix build for the 64bit Hurd.

Message ID 4195526ce5a0ee3819027794156fedf5fea24c8b.1731999203.git.janneke@gnu.org
State New
Headers show
Series Add support for x86_64-gnu, aka the 64bit Hurd. | expand

Commit Message

Janneke Nieuwenhuizen Nov. 19, 2024, 6:55 a.m. UTC
* gnu/packages/guile-xyz.scm (guile-fibers)[arguments]: Also modify phases for
the 64bit Hurd.

Change-Id: I780f6a92418b49e5fe0d23eb1c90e155216f1428
---
 gnu/packages/guile-xyz.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 044a491259..f0f16125d6 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -856,7 +856,7 @@  (define-public guile-fibers
      (list #:make-flags
            #~(list "GUILE_AUTO_COMPILE=0")
            #:phases
-           (if (target-x86-64?)
+           (if (and (target-x86-64?) (not (target-hurd?)))
                #~%standard-phases
                #~(modify-phases %standard-phases
                    (add-before 'check 'disable-some-tests