[bug#78370] gnu: system-settings: Adjust inputs.
Commit Message
* gnu/packages/kde-plasma.scm (system-settings)
[inputs]: Add missing inputs for online accounts integration.
`qtwebengine' propagates the `QTWEBENGINEPROCESS_PATH' to the `qt-wrap' phase,
this is required as an input of `system-settings' because the NextCloud
account integration, provided `kaccounts-providers', relies on the
`systemsettings' binary invoking `QtWebEngineProcess'.
Change-Id: I5af522af5c8ebd271165316ea41ada8a71c1ecfe
---
gnu/packages/kde-plasma.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
base-commit: 0afc996fa9d95d568e6ba7afd726d04f90c4513d
@@ -3103,7 +3103,9 @@ (define-public system-settings
"18vx02nwd7fq3r3smrq3yviz6x4n17b8kidrnfkmkdycfxi2dsn0"))))
(build-system qt-build-system)
(native-inputs (list extra-cmake-modules))
- (inputs (list kauth
+ (inputs (list kaccounts-integration
+ kaccounts-providers
+ kauth
kcrash
kitemviews
kitemmodels
@@ -3125,7 +3127,8 @@ (define-public system-settings
knotifications
krunner
plasma-workspace
- qtdeclarative))
+ qtdeclarative
+ qtwebengine))
(arguments (list #:qtbase qtbase))
(synopsis "Control center to configure Plasma Desktop")
(description "This package provides configuration UI for Plasma Desktop.")