diff mbox series

[bug#57659] gnu: Add blesh.

Message ID 412cc868c48c12fd60239cea4bf2797daa93919c.1662603065.git.kiasoc5@disroot.org
State Accepted
Headers show
Series [bug#57659] gnu: Add blesh. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

kiasoc5 Sept. 8, 2022, 2:11 a.m. UTC
* gnu/packages/bash.scm (blesh): New variable.
---
 gnu/packages/bash.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: b45a44eaad890f31d9418dbb8cb14e3ee1d83c19

Comments

Christopher Baines Sept. 11, 2022, 7:59 p.m. UTC | #1
kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/bash.scm (blesh): New variable.
> ---
>  gnu/packages/bash.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
> index 72758560cd..2460c7cc00 100644
> --- a/gnu/packages/bash.scm
> +++ b/gnu/packages/bash.scm
> @@ -44,6 +44,7 @@ (define-module (gnu packages bash)
>    #:use-module (guix gexp)
>    #:use-module (guix monads)
>    #:use-module (guix store)
> +  #:use-module (guix build-system copy)
>    #:use-module (guix build-system gnu)
>    #:use-module (guix build-system trivial)
>    #:autoload   (guix gnupg) (gnupg-verify*)
> @@ -456,3 +457,25 @@ (define-public bash-ctypes
>  function interface (FFI) directly in your shell.  In other words, it allows
>  you to call routines in shared libraries from within Bash.")
>      (license license:expat)))
> +
> +(define-public blesh
> +  (package
> +    (name "blesh")
> +    (version "0.3.3")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://github.com/akinomyoga/ble.sh/releases/download/v"
> +			   version "/ble-" version ".tar.xz"))
> +       (sha256
> +        (base32
> +         "0fpkacw0r5zhby1wpsirlzq4w1yq1fmhivik47l891c2pn1n7rm7"))))
> +    (build-system copy-build-system)
> +    (inputs (list bash))
> +    (arguments
> +      (list
> +	#:install-plan #~'(("." "share/blesh"))))
> +    (home-page "https://github.com/akinomyoga/ble.sh/")
> +    (synopsis "A line editor written in pure Bash")
> +    (description "Bash Line Editor (ble.sh) is a command line editor written in pure Bash which replaces the default GNU Readline. It adds syntax highlighting, auto suggestions, vim modes, and more to Bash interactive sessions.")
> +    (license license:bsd-3)))

Simple things first, the linter makes a number of complaints. There are
tab characters on a couple of lines and some issues with the formatting
of the description.

Maybe more importantly, this package uses the copy build system, but it
looks like ble.sh should be built with make. I realise that the output
of this build process is a mostly readable shell script, but the Guix
package should still build the source to generate it. Does that make
sense?

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 72758560cd..2460c7cc00 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -44,6 +44,7 @@  (define-module (gnu packages bash)
   #:use-module (guix gexp)
   #:use-module (guix monads)
   #:use-module (guix store)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
   #:autoload   (guix gnupg) (gnupg-verify*)
@@ -456,3 +457,25 @@  (define-public bash-ctypes
 function interface (FFI) directly in your shell.  In other words, it allows
 you to call routines in shared libraries from within Bash.")
     (license license:expat)))
+
+(define-public blesh
+  (package
+    (name "blesh")
+    (version "0.3.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/akinomyoga/ble.sh/releases/download/v"
+			   version "/ble-" version ".tar.xz"))
+       (sha256
+        (base32
+         "0fpkacw0r5zhby1wpsirlzq4w1yq1fmhivik47l891c2pn1n7rm7"))))
+    (build-system copy-build-system)
+    (inputs (list bash))
+    (arguments
+      (list
+	#:install-plan #~'(("." "share/blesh"))))
+    (home-page "https://github.com/akinomyoga/ble.sh/")
+    (synopsis "A line editor written in pure Bash")
+    (description "Bash Line Editor (ble.sh) is a command line editor written in pure Bash which replaces the default GNU Readline. It adds syntax highlighting, auto suggestions, vim modes, and more to Bash interactive sessions.")
+    (license license:bsd-3)))