diff mbox series

[bug#63637] gnu: tpm2-tools: New variable

Message ID 41233051ac8124b990c601fcfe7abdbf35b4e916.1684736552.git.felix.lechner@lease-up.com
State New
Headers show
Series [bug#63637] gnu: tpm2-tools: New variable | expand

Commit Message

Felix Lechner May 22, 2023, 6:27 a.m. UTC
* gnu/packages/hardware.scm (tpm-tools): New variable.
---
 gnu/packages/hardware.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)


base-commit: 849286ba66c96534bddc04df1a47d5692cbc977e

Comments

Felix Lechner May 22, 2023, 2:46 p.m. UTC | #1
Hi,

I should have mentioned that the programs can help analyze the TPM 2.0
event log that shows the hashes of so-called Option ROMs. After the
Microblows keys are removed, such embedded firmwares (including,
possibly, on video cards) will only run after their hashes were
enrolled. Not doing so can soft-brick a device.

Kind regards
Felix
Nicolas Goaziou July 1, 2023, 11:15 a.m. UTC | #2
Hello,

Felix Lechner via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/hardware.scm (tpm-tools): New variable.

Applied, with the change below. Thank you.

> +    (description
> +     "User tools for the Trusted Computing Group's (TCG) TPM2 Software Stack
> +(TSS).  These programs hepl with common tasks such as key management,
> +attestation, encryption, and signing.")

Descriptions should consist of complete sentences:

  "This package provides user tools for..."

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index c23299d1db..f20657cdef 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -61,6 +61,7 @@  (define-module (gnu packages hardware)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
+  #:use-module (gnu packages haskell-xyz)
   #:use-module (gnu packages high-availability)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
@@ -1313,6 +1314,36 @@  (define-public tpm2-tss
 and libtss2-tcti-mssim.")
     (license license:bsd-2)))
 
+(define-public tpm2-tools
+  (package
+    (name "tpm2-tools")
+    (version "5.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/tpm2-software/tpm2-tools/"
+                           "releases/download/" version "/"
+                           "tpm2-tools-" version ".tar.gz"))
+       (sha256
+        (base32 "08y16q92dh7frsyw0zlm3q9gsfqyls0li248s2pgsysk633lknqz"))))
+    (build-system gnu-build-system)
+    (native-inputs (list autoconf
+                         automake
+                         curl
+                         libtool
+                         gnu-gettext
+                         openssl
+                         pandoc
+                         pkg-config
+                         tpm2-tss))
+    (home-page "https://github.com/tpm2-software/tpm2-tools")
+    (synopsis "Tools for the Trusted Platform Module (TPM 2.0)")
+    (description
+     "User tools for the Trusted Computing Group's (TCG) TPM2 Software Stack
+(TSS).  These programs hepl with common tasks such as key management,
+attestation, encryption, and signing.")
+    (license license:bsd-3)))
+
 (define-public libcpuid
   ;; We need to remove blobs from the source, first we have to isolate the blob
   ;; source in build system.