diff mbox series

[bug#64362,v1,2/3] gnu: Add python-anvil-parser.

Message ID 40c7484f-a0ac-86de-ad5b-22e0bf1b1b1e@disroot.org
State New
Headers show
Series [bug#64362,v1,1/3] gnu: Add python-nbt. | expand

Commit Message

Adam Faiz July 1, 2023, 11:42 a.m. UTC
From 20f99f50f698235c88daebd3a9638e96b7a61dbf Mon Sep 17 00:00:00 2001
Message-Id: <20f99f50f698235c88daebd3a9638e96b7a61dbf.1688211506.git.adam.faiz@disroot.org>
In-Reply-To: <8886dce031a397faa7f9bbf15cc1a195667ad9c6.1688211506.git.adam.faiz@disroot.org>
References: <8886dce031a397faa7f9bbf15cc1a195667ad9c6.1688211506.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 30 Jun 2023 16:44:20 +0800
Subject: [PATCH v1 2/3] gnu: Add python-anvil-parser.

* gnu/packages/game-development.scm (python-anvil-parser): New variable.
---
 gnu/packages/game-development.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 446a3c2b1b..503c5e1f73 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -442,6 +442,28 @@  (define-public nml
 files) into @file{.grf} and/or @file{.nfo} files.")
     (license license:gpl2+)))
 
+(define-public python-anvil-parser
+  (let ((commit "27544bb41f035617be130a209a84371cbaf837cc")
+        (revision "0"))
+  (package
+    (name "python-anvil-parser")
+    (version (git-version "0.9.0" revision commit))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/0xTiger/anvil-parser")
+             (commit commit)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "196nli36pz4sllx1m8jlys661hgbxhcxr2c4545fqb4nd27hhwy7"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-frozendict python-nbt))
+    (home-page "https://github.com/0xTiger/anvil-parser")
+    (synopsis "Anvil file format parser")
+    (description "This package provides an Anvil file format parser.")
+    (license license:expat))))
+
 (define-public python-nbt
   (package
     (name "python-nbt")