diff mbox series

[bug#48638] PSOPT (ADOL-C and ColPack)

Message ID 40c0b92a-945a-491f-aef2-51a1c0d2711d@www.fastmail.com
State New
Headers show
Series [bug#48638] PSOPT (ADOL-C and ColPack) | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Eric Brown May 25, 2021, 5:04 a.m. UTC
Patches attached.

Comments

M May 26, 2021, 5:24 p.m. UTC | #1
Eric Brown schreef op di 25-05-2021 om 00:04 [-0500]:
> Patches attached.

> +    (home-page "https://psopt.org")
psopt.org is dead. It states:

‘This Domain Name Has Expired - Renewal Instructions’

Greetings,
Maxime.
Eric Brown May 26, 2021, 5:37 p.m. UTC | #2
Hello Maxime,

Thanks for your feedback. Indeed this has only happened recently, as I had been accessing it to learn it.

I am Cc:'ing the author and see if he knows anything about it.  I think also maybe the GitHub page would work:

https://github.com/PSOPT/psopt

Thanks,
Eric

On Wed, May 26, 2021, at 12:24 PM, Maxime Devos wrote:
> Eric Brown schreef op di 25-05-2021 om 00:04 [-0500]:
> > Patches attached.
> 
> > +    (home-page "https://psopt.org")
> psopt.org is dead. It states:
> 
> ‘This Domain Name Has Expired - Renewal Instructions’
> 
> Greetings,
> Maxime.
> 
> Attachments:
> * signature.asc
Victor Becerra May 30, 2021, 5:18 a.m. UTC | #3
Hello

Many thanks for your email.

Yes, I saw there is a problem with the website. Thank you for pointing it
out.

Upon investigation, I realized that the credit card I was using for
automated payments of the domain expired and I did not see the reminders in
time, so that the domain lapsed.

I will ask Google to see if they can reinstate it, as there appears to be
no easy way to do it myself. If that does not work I may have to get a new
domain.

As you correctly indicate PSOPT and its documentation can be accessed from
the GitHub page.

Best wishes,

Victor Becerra



On Wed, 26 May 2021 at 18:37, Eric Brown <ecbrown@ericcbrown.com> wrote:

> Hello Maxime,
>
> Thanks for your feedback. Indeed this has only happened recently, as I had
> been accessing it to learn it.
>
> I am Cc:'ing the author and see if he knows anything about it.  I think
> also maybe the GitHub page would work:
>
> https://github.com/PSOPT/psopt
>
> Thanks,
> Eric
>
> On Wed, May 26, 2021, at 12:24 PM, Maxime Devos wrote:
> > Eric Brown schreef op di 25-05-2021 om 00:04 [-0500]:
> > > Patches attached.
> >
> > > +    (home-page "https://psopt.org")
> > psopt.org is dead. It states:
> >
> > ‘This Domain Name Has Expired - Renewal Instructions’
> >
> > Greetings,
> > Maxime.
> >
> > Attachments:
> > * signature.asc
>
diff mbox series

Patch

From 8c5ad02f0bedb41f86ef05d533f2ff0917d8361f Mon Sep 17 00:00:00 2001
From: Eric Brown <ecbrown@ericcbrown.com>
Date: Mon, 24 May 2021 23:40:05 -0500
Subject: [PATCH 3/3] gnu: psopt: Add psopt.

* gnu/packages/maths.scm (psopt): New variable.
---
 gnu/packages/maths.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6d1d3dc0ca..d772d6b046 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1884,6 +1884,45 @@  function.  It uses C++ overloading to record arithmetic operations, which it
 plays back later in various ways to calculate the requested values.")
     (license license:epl1.0)))
 
+(define-public psopt
+  (package
+    (name "psopt")
+    (version "5.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/PSOPT/psopt")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0y56lag51xdmpcak0wydzrkghypfn884nw8rd62gwgzgxgz0ls9f"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f ; no test suite
+       #:configure-flags
+       `(,(string-append "-Dadolc_INCLUDE_DIR="
+                         (assoc-ref %build-inputs "adol-c") "/include")
+         ,(string-append "-Dadolc_LIBRARY="
+                         (assoc-ref %build-inputs "adol-c") "/lib"))))
+    (native-inputs
+     `(("python-2" ,python-2)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("adol-c" ,adol-c)
+       ("colpack" ,colpack)
+       ("eigen" ,eigen)
+       ("ipopt" ,ipopt)
+       ("lapack" ,openblas)))
+    (home-page "https://psopt.org")
+    (synopsis "Optimal Control Software")
+    (description
+     "PSOPT is an open source optimal control package written in C++ that uses
+direct collocation methods. These methods solve optimal control problems by
+approximating the time-dependent variables using global or local
+polynomials.")
+    (license license:lgpl2.1)))
+
 (define-public libflame
   (package
     (name "libflame")
-- 
2.31.1