diff mbox series

[bug#43701] gnu: SuiteSparse: Update to 5.8.1.

Message ID 40966690-465E-4B57-8A3E-B195B8791433@greghogan.com
State Accepted
Headers show
Series [bug#43701] gnu: SuiteSparse: Update to 5.8.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Greg Hogan Sept. 29, 2020, 12:01 p.m. UTC
From 0d8692dfebc6ac4b515c06612ab8da4c898719eb Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Tue, 29 Sep 2020 11:54:38 +0000
Subject: [PATCH] gnu: SuiteSparse: Update to 5.8.1.

* gnu/packages/maths.scm (suitesparse): Update to 5.8.1.
[arguments]: Remove unnecessary flag and use default blas and lapack.
[inputs]: Add new dependencies for SLIP_LU component.

---
 gnu/packages/maths.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

Ludovic Courtès Oct. 1, 2020, 10:48 a.m. UTC | #1
Hi,

Greg Hogan <code@greghogan.com> skribis:

> From 0d8692dfebc6ac4b515c06612ab8da4c898719eb Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Tue, 29 Sep 2020 11:54:38 +0000
> Subject: [PATCH] gnu: SuiteSparse: Update to 5.8.1.
>
> * gnu/packages/maths.scm (suitesparse): Update to 5.8.1.
> [arguments]: Remove unnecessary flag and use default blas and lapack.
> [inputs]: Add new dependencies for SLIP_LU component.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 005f29eded..da95524807 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3863,7 +3863,7 @@  Fresnel integrals, and similar related functions as well.")
 (define-public suitesparse
   (package
     (name "suitesparse")
-    (version "5.7.1")
+    (version "5.8.1")
     (source
      (origin
        (method git-fetch)
@@ -3873,7 +3873,7 @@  Fresnel integrals, and similar related functions as well.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "174p3l78kv9gaa0i5hflyai2ydwnjzh34k9938sl4aa3li0543s8"))
+         "0qjlyfxs8s48rs63c2fzspisgq1kk4bwkgnhmh125hgkdhrq2w1c"))
        (patches (search-patches "suitesparse-mongoose-cmake.patch"))
        (modules '((guix build utils)))
        (snippet
@@ -3886,7 +3886,6 @@  Fresnel integrals, and similar related functions as well.")
      '(#:tests? #f  ;no "check" target
        #:make-flags
        (list "CC=gcc"
-             "BLAS=-lblas"
              "TBB=-ltbb"
              "MY_METIS_LIB=-lmetis"
              ;; Flags for cmake (required to build GraphBLAS and Mongoose)
@@ -3908,6 +3907,8 @@  Fresnel integrals, and similar related functions as well.")
     (inputs
      `(("tbb" ,tbb)
        ("lapack" ,lapack)
+       ("gmp" ,gmp)
+       ("mpfr" ,mpfr)
        ("metis" ,metis)))
     (native-inputs
      `(("cmake" ,cmake-minimal)