[bug#77561,v2] gnu: emacs-org-roam: Update to 2.2.2-2.046822b.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-org-roam): Update to 2.2.2-2.046822b.
- Update to recent commit
- Produce info document using provided makefile
- Put stages in order
- Remove unnecessary input dependencies
Change-Id: I70cdd629a92145ad4cf5d965e53ce34f71117c7f
---
gnu/packages/emacs-xyz.scm | 33 ++++++++++++++-------------------
1 file changed, 14 insertions(+), 19 deletions(-)
base-commit: 80826c6e038997dc47eb455888f0feaa38c08bf5
--
2.49.0
Comments
On Sun, 06 Apr 2025 15:40:26 +0800,
Cayetano Santos wrote:
>
> * gnu/packages/emacs-xyz.scm (emacs-org-roam): Update to 2.2.2-2.046822b.
>
> - Update to recent commit
> - Produce info document using provided makefile
> - Put stages in order
> - Remove unnecessary input dependencies
Please write the changelog in the following format:
--8<---------------cut here---------------start------------->8---
[arguments]<#:phases>: ...
[propagated-inputs]: Remove ...
--8<---------------cut here---------------end--------------->8---
In case you didn't know, this changelog style is described in GNU Coding
Standards, ‘info (standards) Change Logs’, though in practice not strictly
followed in Guix.
@@ -40163,8 +40163,8 @@ (define-public emacs-orca
(license license:gpl3+))))
(define-public emacs-org-roam
- (let ((commit "0b9fcbc97b65b349826e63bad89ca121a08fd2be")
- (revision "1"))
+ (let ((commit "046822b512ffecdee7d110f73dd3a511802ca590")
+ (revision "2"))
(package
(name "emacs-org-roam")
(version (git-version "2.2.2" revision commit))
@@ -40176,15 +40176,23 @@ (define-public emacs-org-roam
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "04vqwrsb71jdb66fkahmxwvx8cssgqamrradbdgp3ygf8alwc7ml"))))
+ (base32 "0jbj48glh0r6fkb0lk1xb9067x2myp3krkw2byycijwdq1nlqzv2"))))
(build-system emacs-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'make-info
+ (lambda _
+ (invoke "make" "-C" "doc" "info")
+ (copy-file "doc/org-roam.info" "org-roam.info")))
+ (add-after 'make-info 'install-image
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "doc/images/org-ref-citelink.png"
+ (string-append #$output "/share/info/images"))))
;; Move the extensions source files to the top level, which
;; is included in the EMACSLOADPATH.
- (add-after 'unpack 'move-source-files
+ (add-after 'install-image 'move-source-files
(lambda _
(let ((el-files (find-files "./extensions" ".*\\.el$")))
(for-each (lambda (f)
@@ -40195,17 +40203,7 @@ (define-public emacs-org-roam
(make-file-writable "org-roam-graph.el")
(emacs-substitute-variables "org-roam-graph.el"
("org-roam-graph-executable"
- (search-input-file inputs "/bin/dot")))))
- (add-after 'install 'install-image
- (lambda* (#:key outputs #:allow-other-keys)
- (install-file "doc/images/org-ref-citelink.png"
- (string-append #$output "/share/info/images"))))
- (add-after 'install-image 'make-info
- (lambda* (#:key outputs #:allow-other-keys)
- (with-directory-excursion "doc"
- (invoke "makeinfo" "-o" "org-roam.info" "org-roam.texi")
- (install-file "org-roam.info"
- (string-append #$output "/share/info"))))))))
+ (search-input-file inputs "/bin/dot"))))))))
(inputs
(list graphviz))
(native-inputs
@@ -40213,10 +40211,7 @@ (define-public emacs-org-roam
(propagated-inputs
(list emacs-dash
emacs-emacsql
- emacs-f
- emacs-magit
- emacs-org
- emacs-s))
+ emacs-magit))
(home-page "https://github.com/org-roam/org-roam/")
(synopsis "Non-hierarchical note-taking with Org mode")
(description "Emacs Org Roam is a solution for taking non-hierarchical