diff mbox series

[bug#69276,2/2] gnu: libtorrent-rasterbar: Use gexps and new input style.

Message ID 405ac53a-7195-4b9f-db06-022e6bb3433c@disroot.org
State New
Headers show
Series [bug#69276] gnu: libtorrent-rasterbar: Update to 2.0.10. | expand

Commit Message

Adam Faiz Aug. 6, 2024, 1:09 p.m. UTC
From 646cc0c6857c41564eda8ccc0ade07ae16a18a6c Mon Sep 17 00:00:00 2001
Message-ID: <646cc0c6857c41564eda8ccc0ade07ae16a18a6c.1722949379.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1722949379.git.adam.faiz@disroot.org>
References: <cover.1722949379.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Tue, 6 Aug 2024 20:55:13 +0800
Subject: [PATCH 2/2] gnu: libtorrent-rasterbar: Use gexps and new input style.

* gnu/packages/bittorrent.scm (libtorrent-rasterbar)[arguments]: Use gexps.
[native-inputs]: Drop labels.
---
 gnu/packages/bittorrent.scm | 75 +++++++++++++++++++------------------
 1 file changed, 38 insertions(+), 37 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index abc598f7fa..fa2765da5b 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -433,33 +433,34 @@  (define-public libtorrent-rasterbar
         (base32 "0pc8rbcp7njbx8m02z47pcbbwcp5cjggbgq4sfjc19dc3n65p4zw"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:configure-flags '("-Dpython-bindings=ON"
-                           "-Dbuild_tests=ON")
-       ;; Tests do not reliably work when executed in parallel.
-       #:parallel-tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
-             (let* ((disabled-tests
-                     '(
-                       ;; Requires a non-localhost IPv4 interface.
-                       "test_upnp"
-                       ;; test_ssl needs to be run separately.
-                       "test_ssl"))
-                    (exclude-regex (string-append "^("
-                                                  (string-join disabled-tests "|")
-                                                  ")$"))
-                    (timeout "600")
-                    (jobs (if parallel-tests?
-                              (number->string (parallel-job-count))
-                              "1")))
-               (when tests?
-                 (invoke "ctest"
-                         "-E" exclude-regex
-                         "-j" jobs
-                         "--timeout" timeout
-                         "--output-on-failure")
+     (list
+      #:configure-flags
+      #~'("-Dpython-bindings=ON"
+          "-Dbuild_tests=ON")
+      ;; Tests do not reliably work when executed in parallel.
+      #:parallel-tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+              (let* ((disabled-tests
+                      '(;; Requires a non-localhost IPv4 interface.
+                        "test_upnp"
+                        ;; test_ssl needs to be run separately.
+                        "test_ssl"))
+                     (exclude-regex (string-append "^("
+                                                   (string-join disabled-tests "|")
+                                                   ")$"))
+                     (timeout "600")
+                     (jobs (if parallel-tests?
+                               (number->string (parallel-job-count))
+                               "1")))
+                (when tests?
+                  (invoke "ctest"
+                          "-E" exclude-regex
+                          "-j" jobs
+                          "--timeout" timeout
+                          "--output-on-failure")
                  ;; test_ssl relies on bundled TLS certificates with a fixed
                  ;; expiry date.  To ensure succesful builds in the future,
                  ;; fake the time to be roughly that of the release.
@@ -471,17 +472,17 @@  (define-public libtorrent-rasterbar
                  ;;
                  ;; Note: The test_ssl test times out in the ci.
                  ;; Temporarily disable it until that is resolved.
-                 ;; (invoke "faketime" "2022-10-24"
-                 ;;         "ctest"
-                 ;;         "-R" "^test_ssl$"
-                 ;;         "-j" jobs
-                 ;;         "--timeout" timeout
-                 ;;         "--output-on-failure")
-                 )))))))
+                    #;(invoke "faketime" "2022-10-24"
+                            "ctest"
+                            "-R" "^test_ssl$"
+                            "-j" jobs
+                            "--timeout" timeout
+                            "--output-on-failure"))))))))
     (inputs (list boost openssl))
-    (native-inputs `(("libfaketime" ,libfaketime)
-                     ("python-wrapper" ,python-wrapper)
-                     ("pkg-config" ,pkg-config)))
+    (native-inputs
+     (list libfaketime
+           python-wrapper
+           pkg-config))
     (home-page "https://www.libtorrent.org/")
     (synopsis "Feature-complete BitTorrent implementation")
     (description