diff mbox series

[bug#74398,1/4] gnu: Add sonivox.

Message ID 40160a86ed6b263f3e24f75b1cc3bcfd48c02a89.1731857716.git.sughosha@disroot.org
State New
Headers show
Series gnu: vmpk: Update to 0.9.0. | expand

Commit Message

Sughosha Nov. 17, 2024, 3:35 p.m. UTC
* gnu/packages/music.scm (sonivox): New variable.

Change-Id: I50d98ed353264d52d1341baff9dabd5b4e2eecfa
---
 gnu/packages/music.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: 2a6d96425eea57dc6dd48a2bec16743046e32e06
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 980bce6b30..e00dce3561 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5877,6 +5877,33 @@  (define-public sorcer
 the electronic or dubstep genre.")
       (license license:gpl3+))))
 
+(define-public sonivox
+  (package
+    (name "sonivox")
+    (version "3.6.14")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/pedrolcl/sonivox")
+                    (commit (string-append "v" version))))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "0zn9v4lxjpnpdlpnv2px8ch3z0xagmqlvff5pd39pss3mxfp32g0"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:configure-flags
+           #~(list "-DBUILD_TESTING=ON")))
+    (native-inputs
+     (list googletest))
+    (home-page "https://github.com/pedrolcl/sonivox")
+    (synopsis "Fork of the AOSP platform_external_sonivox")
+    (description "This project is a fork of the Android Open Source Project
+@code{platform_external_sonivox}.  It is a Wave Table synthesizer, using
+embedded samples.  It also supports external DLS soundfont files.  It is also a
+real time GM synthesizer.")
+    (license license:asl2.0)))
+
 (define-public sonivox-eas
   (package
     (name "sonivox-eas")