diff mbox series

[bug#72835,qt-team,29/38] gnu: qtwebengine: Update to 6.7.2.

Message ID 4011964d0e23396463134cd1ac50ce7771f10af5.1724775512.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series update qt6 to 6.7.2 | expand

Commit Message

Z572 Aug. 27, 2024, 4:25 p.m. UTC
* gnu/packages/qt.scm (qtwebengine): Update to 6.7.2.
[source]: Adjust preserved-third-party-files.
[inputs]: replace icu4c and re2 with icu4c-75 and re2-next. add fxdiv, fp16.
[arguments]<#:configuration-flags>: Set -DQT_FEATURE_webenginedriver=OFF.
Change-Id: Idbfe2c0b180947c41dabbb55548bbc3aaf217d05

Change-Id: Ib1a9445ca815e2cc065716d408e0d1c5211694c7
---
 gnu/packages/qt.scm | 32 +++++++++++++++++++++-----------
 1 file changed, 21 insertions(+), 11 deletions(-)

Comments

Maxim Cournoyer Sept. 13, 2024, 3:34 p.m. UTC | #1
Hi,

Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

> * gnu/packages/qt.scm (qtwebengine): Update to 6.7.2.
> [source]: Adjust preserved-third-party-files.
> [inputs]: replace icu4c and re2 with icu4c-75 and re2-next. add fxdiv, fp16.
> [arguments]<#:configuration-flags>: Set -DQT_FEATURE_webenginedriver=OFF.
> Change-Id: Idbfe2c0b180947c41dabbb55548bbc3aaf217d05
>
> Change-Id: Ib1a9445ca815e2cc065716d408e0d1c5211694c7

[...]

> @@ -3643,6 +3647,10 @@ (define-public qtwebengine
>                "-DQT_FEATURE_webengine_pepper_plugins=OFF" ;widevine
>                "-DQT_FEATURE_system_ffmpeg=ON"
>
> +              ;; when enable, will "RUNPATH validation failed" on
> +              ;; lib/qt6/libexec/webenginedriver
> +              "-DQT_FEATURE_webenginedriver=OFF"
> +

I'd word it more clearly like:

  ;; The webenginedriver feature is disabled, otherwise the RUNPATH
  ;; validation phase fails.

But! Usually this simply requires augmenting the RUNPATH to look not
only under /lib but also e.g. under /lib/qt6/libexec/webenginedriver;
see for example the 'qt-creator' package, which adds an extra rpath to
lib/qtcreator via the CMAKE_SHARED_LINKER_FLAGS CMake option.

>                ;; Do not artificially limit codec support; video decoding is
>                ;; done by ffmpeg.
>                "-DQT_FEATURE_webengine_proprietary_codecs=ON"
> @@ -3720,9 +3728,9 @@ (define-public qtwebengine
>              (lambda _
>                (invoke "cmake" "--install" ".")))
>            (add-after 'install 'delete-installed-tests
> -                 (lambda _
> -                   (delete-file-recursively
> -                    (string-append #$output "/tests")))))))
> +            (lambda _
> +              (delete-file-recursively
> +               (string-append #$output "/tests")))))))
>      (native-inputs
>       (modify-inputs (package-native-inputs qtwebengine-5)
>         (delete "python2" "python2-six")
> @@ -3734,8 +3742,10 @@ (define-public qtwebengine
>                 python-html5lib)))
>      (inputs
>       (modify-inputs (package-inputs qtwebengine-5)
> +       (replace "icu4c" icu4c-75)
> +       (replace "re2" re2-next)
>         (replace "qtmultimedia" qtmultimedia)
> -       (append libxkbfile xkeyboard-config)))
> +       (append libxkbfile xkeyboard-config fxdiv fp16)))

Please keep the input sorted alphabetically, so

> +       (append fp16 fxdiv libxkbfile xkeyboard-config)))
Z572 Sept. 18, 2024, 2:08 a.m. UTC | #2
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hi,
>
> Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:
>
>> * gnu/packages/qt.scm (qtwebengine): Update to 6.7.2.
>> [source]: Adjust preserved-third-party-files.
>> [inputs]: replace icu4c and re2 with icu4c-75 and re2-next. add fxdiv, fp16.
>> [arguments]<#:configuration-flags>: Set -DQT_FEATURE_webenginedriver=OFF.
>> Change-Id: Idbfe2c0b180947c41dabbb55548bbc3aaf217d05
>>
>> Change-Id: Ib1a9445ca815e2cc065716d408e0d1c5211694c7
>
> [...]
>
>> @@ -3643,6 +3647,10 @@ (define-public qtwebengine
>>                "-DQT_FEATURE_webengine_pepper_plugins=OFF" ;widevine
>>                "-DQT_FEATURE_system_ffmpeg=ON"
>>
>> +              ;; when enable, will "RUNPATH validation failed" on
>> +              ;; lib/qt6/libexec/webenginedriver
>> +              "-DQT_FEATURE_webenginedriver=OFF"
>> +
>
> I'd word it more clearly like:
>
>   ;; The webenginedriver feature is disabled, otherwise the RUNPATH
>   ;; validation phase fails.
>
> But! Usually this simply requires augmenting the RUNPATH to look not
> only under /lib but also e.g. under /lib/qt6/libexec/webenginedriver;
> see for example the 'qt-creator' package, which adds an extra rpath to
> lib/qtcreator via the CMAKE_SHARED_LINKER_FLAGS CMake option.

Unfortunately I have tried many methods, but webenginedriver still uses rpath.

>
>>                ;; Do not artificially limit codec support; video decoding is
>>                ;; done by ffmpeg.
>>                "-DQT_FEATURE_webengine_proprietary_codecs=ON"
>> @@ -3720,9 +3728,9 @@ (define-public qtwebengine
>>              (lambda _
>>                (invoke "cmake" "--install" ".")))
>>            (add-after 'install 'delete-installed-tests
>> -                 (lambda _
>> -                   (delete-file-recursively
>> -                    (string-append #$output "/tests")))))))
>> +            (lambda _
>> +              (delete-file-recursively
>> +               (string-append #$output "/tests")))))))
>>      (native-inputs
>>       (modify-inputs (package-native-inputs qtwebengine-5)
>>         (delete "python2" "python2-six")
>> @@ -3734,8 +3742,10 @@ (define-public qtwebengine
>>                 python-html5lib)))
>>      (inputs
>>       (modify-inputs (package-inputs qtwebengine-5)
>> +       (replace "icu4c" icu4c-75)
>> +       (replace "re2" re2-next)
>>         (replace "qtmultimedia" qtmultimedia)
>> -       (append libxkbfile xkeyboard-config)))
>> +       (append libxkbfile xkeyboard-config fxdiv fp16)))
>
> Please keep the input sorted alphabetically, so

have done.

>
>> +       (append fp16 fxdiv libxkbfile xkeyboard-config)))
Maxim Cournoyer Sept. 26, 2024, 3:50 a.m. UTC | #3
Hi,

Z572 <zhengjunjie@iscas.ac.cn> writes:

> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> Hi,
>>
>> Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:
>>
>>> * gnu/packages/qt.scm (qtwebengine): Update to 6.7.2.
>>> [source]: Adjust preserved-third-party-files.
>>> [inputs]: replace icu4c and re2 with icu4c-75 and re2-next. add fxdiv, fp16.
>>> [arguments]<#:configuration-flags>: Set -DQT_FEATURE_webenginedriver=OFF.
>>> Change-Id: Idbfe2c0b180947c41dabbb55548bbc3aaf217d05
>>>
>>> Change-Id: Ib1a9445ca815e2cc065716d408e0d1c5211694c7
>>
>> [...]
>>
>>> @@ -3643,6 +3647,10 @@ (define-public qtwebengine
>>>                "-DQT_FEATURE_webengine_pepper_plugins=OFF" ;widevine
>>>                "-DQT_FEATURE_system_ffmpeg=ON"
>>>
>>> +              ;; when enable, will "RUNPATH validation failed" on
>>> +              ;; lib/qt6/libexec/webenginedriver
>>> +              "-DQT_FEATURE_webenginedriver=OFF"
>>> +
>>
>> I'd word it more clearly like:
>>
>>   ;; The webenginedriver feature is disabled, otherwise the RUNPATH
>>   ;; validation phase fails.
>>
>> But! Usually this simply requires augmenting the RUNPATH to look not
>> only under /lib but also e.g. under /lib/qt6/libexec/webenginedriver;
>> see for example the 'qt-creator' package, which adds an extra rpath to
>> lib/qtcreator via the CMAKE_SHARED_LINKER_FLAGS CMake option.
>
> Unfortunately I have tried many methods, but webenginedriver still uses rpath.

OK, they must do something hard-coded in their CMake files causing that.

>>
>>>                ;; Do not artificially limit codec support; video decoding is
>>>                ;; done by ffmpeg.
>>>                "-DQT_FEATURE_webengine_proprietary_codecs=ON"
>>> @@ -3720,9 +3728,9 @@ (define-public qtwebengine
>>>              (lambda _
>>>                (invoke "cmake" "--install" ".")))
>>>            (add-after 'install 'delete-installed-tests
>>> -                 (lambda _
>>> -                   (delete-file-recursively
>>> -                    (string-append #$output "/tests")))))))
>>> +            (lambda _
>>> +              (delete-file-recursively
>>> +               (string-append #$output "/tests")))))))
>>>      (native-inputs
>>>       (modify-inputs (package-native-inputs qtwebengine-5)
>>>         (delete "python2" "python2-six")
>>> @@ -3734,8 +3742,10 @@ (define-public qtwebengine
>>>                 python-html5lib)))
>>>      (inputs
>>>       (modify-inputs (package-inputs qtwebengine-5)
>>> +       (replace "icu4c" icu4c-75)
>>> +       (replace "re2" re2-next)
>>>         (replace "qtmultimedia" qtmultimedia)
>>> -       (append libxkbfile xkeyboard-config)))
>>> +       (append libxkbfile xkeyboard-config fxdiv fp16)))
>>
>> Please keep the input sorted alphabetically, so
>
> have done.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 494457fb47..0102c0f27c 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3336,14 +3336,14 @@  (define-public qtwebengine-5
 (define-public qtwebengine
   (package
     (name "qtwebengine")
-    (version "6.6.3")
+    (version "6.7.2")
     (source
      (origin
        (method url-fetch)
        (uri (qt-url name version))
        (sha256
         (base32
-         "016qvbmdja2abajvsznnjdvblrmzgvs8s2dzlxws30hvna1xqavw"))
+         "1lgz0mj9lw4ii1c8nkbr0ll02xzx8i6n7wvvn21f72sdb5smhxf7"))
        (modules '((ice-9 ftw)
                   (ice-9 match)
                   (srfi srfi-1)
@@ -3378,10 +3378,10 @@  (define-public qtwebengine
                     "third_party/angle/src/common/third_party/xxhash"
                     "third_party/angle/src/third_party/libXNVCtrl" ;Expat
                     "third_party/angle/src/third_party/volk"
-                    "third_party/angle/src/third_party/systeminfo"
                     "third_party/angle/src/third_party/ceval"
                     "third_party/axe-core"
                     "third_party/blink"
+                    "third_party/bidimapper"
                     "third_party/boringssl"
                     "third_party/boringssl/src/third_party/fiat"
                     "third_party/breakpad"
@@ -3405,6 +3405,7 @@  (define-public qtwebengine
                     "third_party/crashpad/crashpad/third_party/lss"
                     "third_party/crashpad/crashpad/third_party/zlib"
                     "third_party/crc32c"
+                    "third_party/d3"
                     "third_party/dav1d"
                     "third_party/dawn"
                     "third_party/dawn/third_party/gn/webgpu-cts"
@@ -3418,7 +3419,6 @@  (define-public qtwebengine
                     "third_party/devtools-frontend/src/front_end/third_party/codemirror"
                     "third_party/devtools-frontend/src/front_end/third_party/codemirror.next"
                     "third_party/devtools-frontend/src/front_end/third_party/diff"
-                    "third_party/devtools-frontend/src/front_end/third_party/i18n"
                     "third_party/devtools-frontend/src/front_end/third_party/intl-messageformat"
                     "third_party/devtools-frontend/src/front_end/third_party/lighthouse"
                     "third_party/devtools-frontend/src/front_end/third_party/lit"
@@ -3428,7 +3428,10 @@  (define-public qtwebengine
                     "third_party/devtools-frontend/src/front_end/third_party/\
 puppeteer/package/lib/esm/third_party/mitt"
                     "third_party/devtools-frontend/src/front_end/third_party/\
+puppeteer/package/lib/esm/third_party/rxjs"
+                    "third_party/devtools-frontend/src/front_end/third_party/\
 vscode.web-custom-data"
+                    "third_party/devtools-frontend/src/front_end/third_party/puppeteer-replay"
                     "third_party/devtools-frontend/src/third_party/pyjson5"
                     "third_party/devtools-frontend/src/front_end/third_party/wasmparser"
                     "third_party/devtools-frontend/src/third_party/typescript"
@@ -3471,6 +3474,7 @@  (define-public qtwebengine
                     "third_party/libaom/source/libaom/third_party/vector"
                     "third_party/libaom/source/libaom/third_party/x86inc"
                     "third_party/libavif"
+                    "third_party/libavifinfo"
                     "third_party/libevent"
                     "third_party/libgav1"
                     "third_party/libjingle_xmpp"
@@ -3505,7 +3509,6 @@  (define-public qtwebengine
                     "third_party/one_euro_filter"
                     "third_party/openscreen" ;BSD-3
                     "third_party/openscreen/src/third_party/tinycbor" ;Expat
-                    "third_party/openscreen/src/third_party/mozilla" ;MPL1.1/GPL2+/LGPL2.1+, BSD-3
                     "third_party/openh264"
                     "third_party/opus/src/include/opus.h"
                     "third_party/opus/src/include/opus_custom.h"
@@ -3522,7 +3525,6 @@  (define-public qtwebengine
                     "third_party/pdfium/third_party/lcms"
                     "third_party/pdfium/third_party/libopenjpeg"
                     "third_party/pdfium/third_party/libtiff"
-                    "third_party/pdfium/third_party/skia_shared"
                     "third_party/pdfium/third_party/freetype/include/pstables.h" ;FreeType
                     "third_party/perfetto"
                     "third_party/perfetto/protos/third_party/chromium"
@@ -3538,6 +3540,7 @@  (define-public qtwebengine
                     "third_party/re2"
                     "third_party/rnnoise"
                     "third_party/ruy" ;ASL2.0
+                    "third_party/selenium-atoms"
                     "third_party/s2cellid" ;ASL2.0
                     "third_party/securemessage" ;ASL2.0
                     "third_party/shell-encryption" ;ASL2.0
@@ -3567,7 +3570,7 @@  (define-public qtwebengine
                     "third_party/vulkan-deps/vulkan-tools"
                     "third_party/vulkan-deps/vulkan-validation-layers"
                     "third_party/vulkan_memory_allocator"
-                    "third_party/web-animations-js"
+                    "third_party/webgpu-cts"
                     "third_party/webrtc"
                     "third_party/webrtc/common_audio/third_party/ooura"
                     "third_party/webrtc/common_audio/third_party/spl_sqrt_floor"
@@ -3583,6 +3586,7 @@  (define-public qtwebengine
                     "third_party/wuffs"
                     "third_party/x11proto"
                     "third_party/xnnpack" ;BSD-3
+                    "third_party/zstd"
                     "third_party/zlib" ;TODO: make pdfium use system version
                     "third_party/zxcvbn-cpp" ;Expat
                     "url/third_party/mozilla"
@@ -3643,6 +3647,10 @@  (define-public qtwebengine
               "-DQT_FEATURE_webengine_pepper_plugins=OFF" ;widevine
               "-DQT_FEATURE_system_ffmpeg=ON"
 
+              ;; when enable, will "RUNPATH validation failed" on
+              ;; lib/qt6/libexec/webenginedriver
+              "-DQT_FEATURE_webenginedriver=OFF"
+
               ;; Do not artificially limit codec support; video decoding is
               ;; done by ffmpeg.
               "-DQT_FEATURE_webengine_proprietary_codecs=ON"
@@ -3720,9 +3728,9 @@  (define-public qtwebengine
             (lambda _
               (invoke "cmake" "--install" ".")))
           (add-after 'install 'delete-installed-tests
-                 (lambda _
-                   (delete-file-recursively
-                    (string-append #$output "/tests")))))))
+            (lambda _
+              (delete-file-recursively
+               (string-append #$output "/tests")))))))
     (native-inputs
      (modify-inputs (package-native-inputs qtwebengine-5)
        (delete "python2" "python2-six")
@@ -3734,8 +3742,10 @@  (define-public qtwebengine
                python-html5lib)))
     (inputs
      (modify-inputs (package-inputs qtwebengine-5)
+       (replace "icu4c" icu4c-75)
+       (replace "re2" re2-next)
        (replace "qtmultimedia" qtmultimedia)
-       (append libxkbfile xkeyboard-config)))
+       (append libxkbfile xkeyboard-config fxdiv fp16)))
     (propagated-inputs
      (modify-inputs (package-propagated-inputs qtwebengine-5)
        (replace "qtbase" qtbase)