diff mbox series

[bug#61070] gnu: packages: Add guile-simple-iterators.

Message ID 3jq6J-nEKJum-SbtMkcZRppVnmkz1UHeXuyFOjPr3QSdPe0FGOIAJx8wffakj447SlmPIYle9jgAISNTa-iUK_rz5esDvqtkM0E9nxu64vE=@protonmail.com
State New
Headers show
Series [bug#61070] gnu: packages: Add guile-simple-iterators. | expand

Commit Message

J. Sims Jan. 26, 2023, 3:16 a.m. UTC
Hello,

guile-simple-iterators is a collection of macros to provide iteration inspired by Racket in Guile. I use them and find them delightful, so I thought other Guix users would appreciate ready access to them.

Thanks,
Juli

Comments

Liliana Marie Prikler Jan. 28, 2023, 6:32 a.m. UTC | #1
Am Donnerstag, dem 26.01.2023 um 03:16 +0000 schrieb J. Sims:

> +(define-public guile-simple-iterators
> +  (let ((commit "50f16a2b2aa57e657e52e19fb3c35bdc182cfa36")
> +        (revision "0"))
> +    (package
> +      (name "guile-simple-iterators")
> +      (version (git-version "0.0.0" revision commit))
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url
> +                      
> "https://gitlab.com/dustyweb/guile-simple-iterators")
> +                      (commit commit)))
> +                (file-name (git-file-name name version))
> +                (sha256
> +                 (base32
> +                 
> "1m1wirlnfwmp5a4rpszd5qsbwabz4ji033w6p2714p1r524ylah8"))))
It's better to dedent this a little so that url can fit on a line.
> +      (build-system guile-build-system)
> +      (native-inputs (list guile-3.0))
> +      (home-page
> "https://gitlab.com/dustyweb/guile-simple-iterators")
> +      (synopsis "Simple iterators for Guile")
> +      (description
> +       "This is a collection of iteration macros for Guile. They are
> inspired by
> +@code{racket}'s family of iterators. Specifically, the following
> iterators are
> +available:
> +@itemize
> +@item @code{for}
> +@item @code{for/map}
> +@item @code{for/c}
> +@item @code{for/fold}
> +@item @code{for/fold-right}
> +@item @code{for/folder}
> +@item @code{folder}
> +@end itemize")
> +      (license license:expat))))
License should be asl2.0.

I'll wait for the CI results and schedule this towards pushing it on
February 5th (with adjustments for the above points).

Cheers
J. Sims Jan. 28, 2023, 5:58 p.m. UTC | #2
Hi,

On Saturday, January 28th, 2023 at 00:32, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:

> I'll wait for the CI results and schedule this towards pushing it on
> February 5th (with adjustments for the above points).

Just to clarify, do I need to make the adjustments or are you making them before pushing? Either way is fine; the wording is just ambiguous.

> It's better to dedent this a little so that url can fit on a line.

I'm not sure I understand what you mean. Dedent the hash? And how so?

Also, thanks for catching the license; I'm not sure why my brain read "Apache Software License 2.0" and went, "Ah, yeah, expat" XD

Thanks,
Juli
Liliana Marie Prikler Jan. 28, 2023, 6:26 p.m. UTC | #3
Am Samstag, dem 28.01.2023 um 17:58 +0000 schrieb J. Sims:
> Hi,
> 
> On Saturday, January 28th, 2023 at 00:32, Liliana Marie Prikler
> <liliana.prikler@gmail.com> wrote:
> 
> > I'll wait for the CI results and schedule this towards pushing it
> > on
> > February 5th (with adjustments for the above points).
> 
> Just to clarify, do I need to make the adjustments or are you making
> them before pushing? Either way is fine; the wording is just
> ambiguous.
They're small changes I can do as a reviewer ;)

> > It's better to dedent this a little so that url can fit on a line.
> 
> I'm not sure I understand what you mean. Dedent the hash? And how so?
No, dedent the entire origin.

Cheers
Liliana Marie Prikler Feb. 5, 2023, 6:20 a.m. UTC | #4
Am Samstag, dem 28.01.2023 um 19:26 +0100 schrieb Liliana Marie
Prikler:
> Am Samstag, dem 28.01.2023 um 17:58 +0000 schrieb J. Sims:
> > Hi,
> > 
> > On Saturday, January 28th, 2023 at 00:32, Liliana Marie Prikler
> > <liliana.prikler@gmail.com> wrote:
> > 
> > > I'll wait for the CI results and schedule this towards pushing it
> > > on February 5th (with adjustments for the above points).
> > 
> > Just to clarify, do I need to make the adjustments or are you
> > making them before pushing? Either way is fine; the wording is just
> > ambiguous.
> They're small changes I can do as a reviewer ;)
> 
> > > It's better to dedent this a little so that url can fit on a
> > > line.
> > 
> > I'm not sure I understand what you mean. Dedent the hash? And how
> > so?
> No, dedent the entire origin.
Aaaand it's pushed.

Thanks
diff mbox series

Patch

From 654847381613f558d80ad8fffb89b1361181d724 Mon Sep 17 00:00:00 2001
From: Juliana Sims <jtsims@protonmail.com>
Date: Wed, 25 Jan 2023 21:07:54 -0600
Subject: [PATCH] gnu: packages: Add guile-simple-iterators.

* gnu/packages/guile-xyz.scm (guile-simple-iterators): Add guile-simple-iterators.
---
 gnu/packages/guile-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 0befff1576..340b2824c2 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2600,6 +2600,41 @@  (define-public guile-lib
     ;; details.
     (license license:gpl3+)))
 
+(define-public guile-simple-iterators
+  (let ((commit "50f16a2b2aa57e657e52e19fb3c35bdc182cfa36")
+        (revision "0"))
+    (package
+      (name "guile-simple-iterators")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url
+                       "https://gitlab.com/dustyweb/guile-simple-iterators")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1m1wirlnfwmp5a4rpszd5qsbwabz4ji033w6p2714p1r524ylah8"))))
+      (build-system guile-build-system)
+      (native-inputs (list guile-3.0))
+      (home-page "https://gitlab.com/dustyweb/guile-simple-iterators")
+      (synopsis "Simple iterators for Guile")
+      (description
+       "This is a collection of iteration macros for Guile. They are inspired by
+@code{racket}'s family of iterators. Specifically, the following iterators are
+available:
+@itemize
+@item @code{for}
+@item @code{for/map}
+@item @code{for/c}
+@item @code{for/fold}
+@item @code{for/fold-right}
+@item @code{for/folder}
+@item @code{folder}
+@end itemize")
+      (license license:expat))))
+
 (define-public guile2.0-lib
   (package
     (inherit guile-lib)

base-commit: a84ceaa8b2e8e121957afea1d1d3fe7c8141cb8d
-- 
2.39.1