diff mbox series

[bug#66694] Revised Patch

Message ID 3fef0f08-1816-4abe-a06c-e858a2b74e58@runbox.com
State New
Headers show
Series [bug#66694] Revised Patch | expand

Commit Message

Jaeme Sifat Oct. 26, 2023, 8:36 p.m. UTC
I revised my patch to include gexps instead of inferior 
propagated-inputs as was advised to me in the guix IRC room.
diff mbox series

Patch

From a70882f584c9406f46325dced316e3ee95c73aee Mon Sep 17 00:00:00 2001
Message-Id: <a70882f584c9406f46325dced316e3ee95c73aee.1698352369.git.jaeme@runbox.com>
From: Jaeme Sifat <jaeme@runbox.com>
Date: Thu, 26 Oct 2023 16:27:45 -0400
Subject: [PATCH] gnu: Add ani-cli.

* gnu/packages/video.scm (ani-cli): New variable.

Signed-off-by: Jaeme Sifat <jaeme@runbox.com>
Change-Id: Id2512a6b22dd2a3bfe44aa525c6a72c9c5082653
---
 gnu/packages/video.scm | 57 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 57 insertions(+)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b4dd7c27ae..70f4808723 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -66,6 +66,7 @@ 
 ;;; Copyright © 2023 Ott Joon <oj@vern.cc>
 ;;; Copyright © 2023 Dominik Delgado Steuter <dds@disroot.org>
 ;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
+;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -116,6 +117,7 @@  (define-module (gnu packages video)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
+  #:use-module (gnu packages bittorrent)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages cdrom)
   #:use-module (gnu packages check)
@@ -194,6 +196,7 @@  (define-module (gnu packages video)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages ssh)
   #:use-module (gnu packages swig)
+  #:use-module (gnu packages terminals)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages textutils)
   #:use-module (gnu packages tls)
@@ -209,6 +212,60 @@  (define-module (gnu packages video)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
+(define-public ani-cli
+  (package
+    (name "ani-cli")
+    (version "4.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pystardust/ani-cli")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1ni9pzjb5qh87iz7c8252bx79qadr1qx6jnkqvvjcqrchh7q473a"))))
+    (build-system copy-build-system)
+    (arguments
+     (list
+      #:install-plan #~'(("ani-cli" "bin/")
+                         ("ani-cli.1" "share/man/man1/"))
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'install 'wrap
+                     (lambda* (#:key inputs #:allow-other-keys)
+                       (define (bin command)
+                         (dirname (search-input-file inputs
+                                                     (string-append "bin/"
+                                                                    command))))
+                       (wrap-program (string-append #$output "/bin/ani-cli")
+                         `("PATH" ":" prefix
+                           ,(map bin
+                                 (list "aria2c"
+                                       "curl"
+                                       "ffmpeg"
+                                       "fzf"
+                                       "grep"
+                                       "mpv"
+                                       "sed"
+                                       "uname"
+                                       "yt-dlp")))))))))
+    (home-page "https://github.com/pystardust/ani-cli")
+    (synopsis "CLI to browse and watch anime")
+    (description
+     "ani-cli is a command-line interface (cli) to browse and watch anime
+(alone AND with friends).  It provides an easy way to stream shows from
+allanime directly.  There is different features such as episode browsing,
+history tracking, streaming at multiple resolutions and much more depending on
+what programs the user has installed.")
+    (inputs (list aria2
+                  coreutils
+                  curl
+                  ffmpeg
+                  fzf
+                  mpv
+                  yt-dlp))
+    (license license:gpl3)))
+
 (define-public transcode
   (package
     (name "transcode")

base-commit: 33f5b747b4a0a508e1ffc94a5bf425cff707c6e3
-- 
2.34.1