diff mbox series

[bug#62859,core-updates] gnu: openldap: core-updates build fixes

Message ID 3fe8a172b84e74c0442d74e48d3eff3cf5e92597.1681566668.git.bjc@spork.org
State New
Headers show
Series [bug#62859,core-updates] gnu: openldap: core-updates build fixes | expand

Commit Message

Brian Cully April 15, 2023, 1:52 p.m. UTC
Change quoting to use gexps, so that ungexping in the build phases doesn't
fail with a syntax error.

Remove references to libldap_r.so and .la, since they're no longer being
built, and manually patching in a .so library when there's no corresponding
.la seems like something that should be removed, with dependent packages
updated, if necessary.

 * gnu/packages/openldap.scm (openldap): update quoting to use gexps, remove
 reference to libldap_r.la, which no longer exists, and remove custom install
 of libldap_r.so.
---
 gnu/packages/openldap.scm | 67 ++++++++++++++++++---------------------
 1 file changed, 30 insertions(+), 37 deletions(-)


base-commit: 7ccf9943029747d4ba97160214f895b365511278
prerequisite-patch-id: 3a0a1be9df9a40370ebadd64ad6163c1a4f2bc4d
prerequisite-patch-id: 04bc0329678ccd5fe51be207d86dc8a4ce969c8b
prerequisite-patch-id: 7edab399c6512d85ed849f0877ccc9602888f1c8

Comments

John Kehayias April 16, 2023, 5:01 a.m. UTC | #1
Hi,

(sending to both related patches, not sure which will be applied and I'm
not familiar with openldap enough to finalize the fixes; also CC'ing
Marius as author of the related commit)

I think the patch-sasl-path phase was meant to be removed, as it was in
https://git.savannah.gnu.org/cgit/guix.git/commit/?h=core-updates&id=0de5e6d6536a7bc94dd71047cf9573d71fa8d4b0
and I believe restored (erroneously I'm guessing) in the master merge in
January. So I think that can be dropped completely.

Hope this helps!
John
diff mbox series

Patch

diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index 7409848795..4d3810ecfb 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -87,44 +87,37 @@  (define-public openldap
     (inputs (list bdb-5.3 cyrus-sasl gnutls libgcrypt zlib))
     (native-inputs (list libtool groff bdb-5.3))
     (arguments
-     `(#:tests? #f
-       #:configure-flags
-       '("--disable-static"
-         ,@(if (%current-target-system)
-               '("--with-yielding_select=yes"
-                 "ac_cv_func_memcmp_working=yes")
-               '()))
-       ;; Disable install stripping as it breaks cross-compiling.
-       #:make-flags '("STRIP=")
-       #:phases
-       (modify-phases %standard-phases
-         ,@(if (%current-target-system)
-               '((add-before 'configure 'fix-cross-gcc
-                   (lambda* (#:key target #:allow-other-keys)
-                     (setenv "CC" (string-append target "-gcc"))
-                     (setenv "STRIP" (string-append target "-strip")))))
-               '())
-         (add-after 'install 'patch-sasl-path
-           ;; Give -L arguments for cyrus-sasl to avoid propagation.
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out"))
-                   (krb5 (assoc-ref inputs "mit-krb5"))) ;propagated from cyrus-sasl
+     (list
+      #:tests? #f
+      #:configure-flags
+      #~(list "--disable-static"
+              #$@(if (%current-target-system)
+                     '("--with-yielding_select=yes"
+                       "ac_cv_func_memcmp_working=yes")
+                     '()))
+      ;; Disable install stripping as it breaks cross-compiling.
+      #:make-flags
+      #~(list "STRIP=")
+      #:phases
+      #~(modify-phases %standard-phases
+          #$@(if (%current-target-system)
+                 '((add-before 'configure 'fix-cross-gcc
+                     (lambda* (#:key target #:allow-other-keys)
+                       (setenv "CC" (string-append target "-gcc"))
+                       (setenv "STRIP" (string-append target "-strip")))))
+                 '())
+          (add-after 'install 'patch-sasl-path
+            ;; Give -L arguments for cyrus-sasl to avoid propagation.
+            (lambda* (#:key inputs outputs #:allow-other-keys)
+              (let ((krb5 (assoc-ref inputs "mit-krb5"))) ;propagated from cyrus-sasl
 
-               ;; The ancient Libtool bundled with OpenLDAP copies the linker flags
-               ;; from Cyrus-SASL and embeds them into its own .la files.  Add an
-               ;; absolute reference to Kerberos so it does not have to be propagated.
-               (substitute* (map (lambda (f) (string-append out "/" f))
-                                 '("lib/libldap.la" "lib/libldap_r.la"))
-                 (("-lkrb5" lib)
-                  (string-append "-L" krb5 "/lib " lib))))))
-         (add-after 'install 'provide-libldap_r
-           (lambda _
-             ;; The re-entrant libldap_r no longer exists since 2.6
-             ;; as it has become the default: provide a linker alias
-             ;; for now.
-             (call-with-output-file (string-append #$output "/lib/libldap_r.so")
-               (lambda (port)
-                 (format port "INPUT ( libldap.so )~%"))))))))
+                ;; The ancient Libtool bundled with OpenLDAP copies the linker flags
+                ;; from Cyrus-SASL and embeds them into its own .la files.  Add an
+                ;; absolute reference to Kerberos so it does not have to be propagated.
+                (substitute* (map (lambda (f) (string-append #$output "/" f))
+                                  '("lib/libldap.la"))
+                  (("-lkrb5" lib)
+                   (string-append "-L" krb5 "/lib " lib)))))))))
     (synopsis "Implementation of the Lightweight Directory Access Protocol")
     (description
      "OpenLDAP is a free implementation of the Lightweight Directory Access Protocol.")