diff mbox series

[bug#38351] gnome-characters V2

Message ID 3fe2fb92b6c3fcf2b5c5dc7b604395d7f75d8dee.camel@disroot.org
State Accepted
Headers show
Series [bug#38351] gnome-characters V2 | expand

Commit Message

Raghav Gururajan Dec. 21, 2019, 3:45 a.m. UTC
Hello Guix!

Please find the new patch attached with this email, for gnome-
characters.

Regards,
Raghav Gururajan.

Comments

Brett Gilio Dec. 21, 2019, 5:11 a.m. UTC | #1
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Raghav Gururajan <raghavgururajan@disroot.org> writes:

> Hello Guix!
>
> Please find the new patch attached with this email, for gnome-
> characters.
>
> Regards,
> Raghav Gururajan.
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index dab2571fba..9146ffc168 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -455,6 +455,34 @@ documents.  This package also contains binaries that can convert XPS documents
>  to other formats.")
>      (license license:lgpl2.1+)))
>  
> +(define-public gnome-characters ;; not gucharmap
> +  (package
> +    (name "gnome-characters") ;; not gucharmap
> +    (version "3.30.0")
> +    (source (origin
> +	      (method url-fetch)
> +	      (uri (string-append "mirror://gnome/sources/gnome-characters/"
> +				  (version-major+minor version) "/gnome-characters-" version ".tar.xz"))
> +	      (sha256
> +	       (base32 
> +		"08cwz39iwgsyyb2wqhb8vfbmh1cwfkgfiy7adp08w7rwqi99x3dp"))))
> +    (build-system meson-build-system)
> +    (native-inputs
> +     `(("glib:bin" ,glib "bin")
> +       ("gtk+:bin" ,gtk+ "bin")
> +       ("pkg-config" ,pkg-config)))
> +    (inputs
> +     `(("gettext" ,gettext-minimal)
> +       ("gjs" ,gjs)
> +       ("gtk+" ,gtk+)
> +       ("libunistring" ,libunistring)))
> +    (synopsis "GNOME Characters")
> +    (description "A simple utility application to find and 
> +		 insert unusual characters. It allows you to quickly find 
> +		 the character you are looking for by searching for keywords.")
> +    (home-page "https://wiki.gnome.org/Design/Apps/CharacterMap")
> +    (license license:bsd-3))
> +
>  (define-public gnome-common
>    (package
>      (name "gnome-common")
>

Hi Raghav,

First, thank you for your submission. I have a few questions and a few
suggestions. I am curious about why you added this comment?

- --8<---------------cut here---------------start------------->8---
(define-public gnome-characters ;; not gucharmap
- --8<---------------cut here---------------end--------------->8---

While I understand where you are coming from, this comment doesn't
really add much information to the code itself. This seems like
something maybe to disclaim in the package description, if that is even
necessary. Just a thought.

Second, your description features an indentation that is not needed. The
`guix lint` command should catch this with the ./pre-inst-env for your
package. If you need help with this, or other stylization for how to
format synopsis and descriptions, feel free to ask.

Lastly, on my end this doesn't appear to be in patch format, but rather
seems like a diff with a .patch extension. We generally use `git
format-patch` for generating patches, which you can find in our
documentation accompanied by a properly formatted commit message and
sub-header.

If you would like some links to the documentation on how to obtain this,
and maybe some tips and tricks on achieving this from GNU Emacs (though
not required), please do let me know.

I am happy to help you, and would like to see your changes be reflected
upstream. Thank you a lot for your work.

- -- 
Brett M. Gilio
GNU Guix, Contributor | GNU Project, Webmaster
[DFC0 C7F7 9EE6 0CA7 AE55 5E19 6722 43C4 A03F 0EEE]
<brettg@gnu.org> <brettg@posteo.net>
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE38DH957mDKeuVV4ZZyJDxKA/Du4FAl39qYMACgkQZyJDxKA/
Du7l2g//UZfo5es5HfddQDWOZc0hGYt3Ih3QvBTZVu3o0/r2tqokEnzvYLwmhkmS
ZuZXS1MRdomGJZ5l80w6EmwESYWIosWewAzDPbCHHBMg+Dyh4omd8Lj7Bh6JF1aK
H14LoQfsc8U86vGlh3FyjXnOq589KZLiNplewnTw/aC1IdQwjsSkIBZOm5b1V+A6
KUPgbgQJja6rqcsZNcXxUxbx/iTuSJxDsp46jGUCOK9TU2AI2ekiI5awP5TyXkQw
LSicDFfF+hpNkXBXPILDa24B3273qE4f7Gm/rngignrVsxZTPwJOLw3CAaYkeMqh
xkxAfh681l8ztdZ9Cmez3RA0CJBEBjIOy+TtB2iJWDkjdH294T1DETlxb5t2H7Qj
pT8ldWRdGtd10MiH0mJbQ3qwSdFPKL+XwwOigKViuUo34eMIZgmXSOVXO0OtC0Ml
fPsOEWnlISXVKdNPIW8pdqoXcRyB4DSl1ZTLw4/BjqI/qXSdUTV077/SC7/HlGn/
Vekpe1sM8koVnAwxbItKKy4+geGuX4Dn1uhgwzbGpnXTNl4xIl1NWJTwuA3SN5Zp
ccx3gqLDShH3a2k7RLM30HUPm53Y8U3M+TXw+SztVbkpgnrQmjlDlySDjc9/vbjP
j9Yb3nno/TW5sbT7r/pivj+93aX+BjReSMxJs5a9pTvGLA9uFnc=
=h6gx
-----END PGP SIGNATURE-----
Ricardo Wurmus Dec. 21, 2019, 10:16 a.m. UTC | #2
Hi,

> Please find the new patch attached with this email, for gnome-
> characters.

Thank you!  I’ve pushed this with commit 4e09f57af8 to the master
branch after a number of small changes:

* applied the patch with “patch -p1 < the-file-that-you-sent.patch”
* removed tabs with M-x untabify
* separated sentences by two spaces
* updated the synopsis
* updated the first sentence of the description
* reflowed the description with M-x fill-paragraph
* changed the home page (so as not to point to the irrelevant design page)
* reflowed the source field
* removed the comments
* moved gettext to the native inputs
* added Python to the native inputs (which is needed for running scripts
  in lib)
* set glib-or-gtk? to #t because the program would crash otherwise
* created a commit (using the yasnippet for “add”) and set you as the
  author (this would not be needed with git formatted patches)

Thanks!

--
Ricardo
Raghav Gururajan Dec. 21, 2019, 10:33 a.m. UTC | #3
Hi Rekado!

Thank you so much for pushing it. I apologize for many small mistakes.
I have asked help-guix for help with guix lint etc. I will try to
revise the other patch I sent for gnome-font-viewer.

Regards,
RG.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index dab2571fba..9146ffc168 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -455,6 +455,34 @@  documents.  This package also contains binaries that can convert XPS documents
 to other formats.")
     (license license:lgpl2.1+)))
 
+(define-public gnome-characters ;; not gucharmap
+  (package
+    (name "gnome-characters") ;; not gucharmap
+    (version "3.30.0")
+    (source (origin
+	      (method url-fetch)
+	      (uri (string-append "mirror://gnome/sources/gnome-characters/"
+				  (version-major+minor version) "/gnome-characters-" version ".tar.xz"))
+	      (sha256
+	       (base32 
+		"08cwz39iwgsyyb2wqhb8vfbmh1cwfkgfiy7adp08w7rwqi99x3dp"))))
+    (build-system meson-build-system)
+    (native-inputs
+     `(("glib:bin" ,glib "bin")
+       ("gtk+:bin" ,gtk+ "bin")
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("gettext" ,gettext-minimal)
+       ("gjs" ,gjs)
+       ("gtk+" ,gtk+)
+       ("libunistring" ,libunistring)))
+    (synopsis "GNOME Characters")
+    (description "A simple utility application to find and 
+		 insert unusual characters. It allows you to quickly find 
+		 the character you are looking for by searching for keywords.")
+    (home-page "https://wiki.gnome.org/Design/Apps/CharacterMap")
+    (license license:bsd-3))
+
 (define-public gnome-common
   (package
     (name "gnome-common")