diff mbox series

[bug#65553,2/6] gnu: Add span-lite.

Message ID 3fe1dc59-aa8a-cbb4-fa37-7e7c33f1f599@disroot.org
State New
Headers show
Series gnu: Add arrayfire. | expand

Commit Message

Adam Faiz Aug. 26, 2023, 6:51 p.m. UTC
From e865289a2ee999420d353b28d584dbe294ac19b1 Mon Sep 17 00:00:00 2001
Message-ID: <e865289a2ee999420d353b28d584dbe294ac19b1.1693075221.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1693075221.git.adam.faiz@disroot.org>
References: <cover.1693075221.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Sun, 27 Aug 2023 02:05:30 +0800
Subject: [PATCH 2/6] gnu: Add span-lite.

* gnu/packages/cpp.scm (span-lite): New variable.
---
 gnu/packages/cpp.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 41f24b0998..6ab3710000 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -759,6 +759,28 @@  (define-public concurrentqueue
 concurrent queue for C++11.")
     (license license:bsd-2)))
 
+(define-public span-lite
+  (package
+    (name "span-lite")
+    (version "0.10.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/martinmoene/span-lite")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0xs7gq84d05h607076c2fvxzx8yb4zy3gmh432379af1yb435yjr"))))
+    (build-system cmake-build-system)
+    (synopsis "C++20-like span header for C++98 and later")
+    (description
+     "Span lite is a single-file header-only library to provide a bounds-safe
+view for sequences of objects.
+  The library provides a C++20-like span for use with C++98 and later.")
+    (home-page "https://github.com/martinmoene/span-lite")
+    (license license:boost1.0)))
+
 (define-public spscqueue
   (package
     (name "spscqueue")