From 3a034f543d5cdf2a66dc0caeab3c424d72c44ffa Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Tue, 7 Jan 2020 00:43:51 -0500
Subject: [PATCH] gnu: Add gnome-boxes.
* gnu/packages/gnome.scm (gnome-boxes): New variable.
---
gnu/packages/gnome.scm | 53 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)
@@ -246,6 +246,59 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public gnome-boxes
+ (package
+ (name "gnome-boxes")
+ (version "3.32.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "15g2w2hzh3945qcwfl3dyqnn5770lzg5cjwwzzj0lw9m98n4ljgn"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:glib-or-gtk? #t
+ #:configure-flags
+ (list "-Dsystemduserunitdir=no"
+ "-Dtmpfilesdir=no"
+ ;; Required for RUNPATH validation.
+ (string-append "-Dc_link_args=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib/gnome-boxes"))))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("adwaita-icon-theme" ,adwaita-icon-theme)
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("freerdp" ,freerdp)
+ ("govirt" ,libgovirt)
+ ("gtk-vnc" ,gtk-vnc)
+ ("itstool" ,itstool)
+ ("json-glib" ,json-glib)
+ ("libarchive" ,libarchive)
+ ("libgudev" ,libgudev)
+ ("libosinfo" ,libosinfo)
+ ("libsecret" ,libsecret)
+ ("libusb" ,libusb)
+ ("libvirt-glib" ,libvirt-glib)
+ ("librest" ,rest)
+ ("spice-gtk" ,spice-gtk)
+ ("tracker" ,tracker)
+ ("tracker-miners" ,tracker-miners)
+ ("vala" ,vala)
+ ("vte" ,vte)
+ ("webkitgtk" ,webkitgtk)))
+ (synopsis "Virtualization for GNOME desktop")
+ (description "GNOME Boxes is a simple application to view, access,
++and manage remote and virtual systems.")
+ (home-page "https://wiki.gnome.org/Apps/Boxes")
+ (license license:gpl2)))
+
(define-public gnome-color-manager
(package
(name "gnome-color-manager")
--
2.24.1