diff mbox series

[bug#72269] gnu: Add sshguard.

Message ID 3fa9d07b28c72ff84fed0a14931a35ed4f65188f.1721812638.git.ashish.is@lostca.se
State New
Headers show
Series [bug#72269] gnu: Add sshguard. | expand

Commit Message

guix-patches--- via July 24, 2024, 9:17 a.m. UTC
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/admin.scm (sshguard): New variable.

Change-Id: I551771ff49af3e852322f2518f0758494aaedee3
---
 gnu/packages/admin.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: d007b64356764f49677c78d82643f1125b5353b7

Comments

Nicolas Goaziou Aug. 20, 2024, 8:53 a.m. UTC | #1
Hello,

> From: Ashish SHUKLA <ashish.is@lostca.se>
> 
> * gnu/packages/admin.scm (sshguard): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 113b8e2481..b5cfa25c62 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -6345,3 +6345,26 @@  (define-public rdfind
 their content instead of their file names.  It is useful for compressing
 backup directories or just finding duplicate files.")
     (license license:gpl2+)))
+
+(define-public sshguard
+  (package
+    (name "sshguard")
+    (version "2.4.3")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://bitbucket.org/sshguard/sshguard.git")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256 (base32 "1dkijr287zpwdz1bjdchxzmwf1sk6vzpkycz1skm25lkaba6nd9r"))))
+    (build-system gnu-build-system)
+    (native-inputs
+      (list autoconf automake bison flex python-docutils))
+
+    (home-page "https://sshguard.net/")
+    (synopsis "Daemon to blocks SSH brute-force attacks")
+    (description "sshguard protects hosts from brute-force attacks against SSH and
+other services.  It aggregates system logs and blocks repeat offenders using one of
+several firewall backends.")
+    (license license:isc)))