[bug#77673] gnu: emacs-vundo: Update to 2.4.0.

Message ID 3fa2b268006e51eab0b504c2f916410e67474a9f.1744190179.git.csantosb@inventati.org
State New
Headers
Series [bug#77673] gnu: emacs-vundo: Update to 2.4.0. |

Commit Message

Cayetano Santos April 9, 2025, 9:16 a.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-vundo): Update to 2.4.0.

[source]: Switch to git fetch.
[arguments]<#:tests>: Activate.
[synopsys]: Fix column.

Change-Id: Ie15c115eb55b2b69cf1fc97cd6b684ac842ed74d
---
 gnu/packages/emacs-xyz.scm | 34 ++++++++++++++++++++++------------
 1 file changed, 22 insertions(+), 12 deletions(-)


base-commit: 90357c6090de8c6befec232996dbc7415112a081
  

Comments

Christopher Baines April 11, 2025, 11:37 a.m. UTC | #1
Cayetano Santos via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-vundo): Update to 2.4.0.
>
> [source]: Switch to git fetch.
> [arguments]<#:tests>: Activate.
> [synopsys]: Fix column.
>
> Change-Id: Ie15c115eb55b2b69cf1fc97cd6b684ac842ed74d
> ---
>  gnu/packages/emacs-xyz.scm | 34 ++++++++++++++++++++++------------
>  1 file changed, 22 insertions(+), 12 deletions(-)

Thanks for the patch, I've pushed this to master as
198fe8bcdf1b7670c599c432edae5aca1f9bc555.

Chris
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 486cb24321..8369dfb631 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -42850,21 +42850,31 @@  (define-public emacs-bitbake-modes
 (define-public emacs-vundo
   (package
     (name "emacs-vundo")
-    (version "2.3.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://elpa.gnu.org/packages/vundo-"
-                                  version ".tar"))
-              (sha256
-               (base32
-                "165y277fi0vp9301hy3pqgfnf160k29n8vri0zyq8a3vz3f8lqrl"))))
+    (version "2.4.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/casouri/vundo/")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "034ynwfk374i27vvfpr13n3qw02ihm0189m8frxfqdbd3hismjkb"))))
     (build-system emacs-build-system)
-    (home-page "https://github.com/casouri/vundo")
+    (arguments
+     (list
+      #:tests? #true
+      #:test-command #~(list "emacs" "-Q" "--batch"
+                             "-l" "vundo.el"
+                             "-l" "test/vundo-test.el"
+                             "-f" "ert-run-tests-batch-and-exit")))
+    (home-page "https://github.com/casouri/vundo/")
     (synopsis "Visualize the undo tree")
     (description
-     "Vundo (visual undo) displays the undo history as a tree and lets you move in the
-tree to go back to previous buffer states.  To use vundo, type @kbd{M-x vundo RET} in
-the buffer you want to undo.  An undo tree buffer should pop up.")
+     "Vundo (visual undo) displays the undo history as a tree and lets you move in
+the tree to go back to previous buffer states.  To use vundo, type @kbd{M-x vundo
+RET} in the buffer you want to undo.  An undo tree buffer should pop up.")
     (license license:gpl3+)))
 
 (define-public emacs-hare-mode