[bug#74710] gnu: ipxe: Update to 24db39fb2983ca83ab5c6ee37cb57a4f7f6f94e6.

Message ID 3f9e450f2533a970a90b08a2e55c4c2f1b3b1db2.1733492271.git.roman@burningswell.com
State New
Headers
Series [bug#74710] gnu: ipxe: Update to 24db39fb2983ca83ab5c6ee37cb57a4f7f6f94e6. |

Commit Message

Roman Scherer Dec. 6, 2024, 1:38 p.m. UTC
  * gnu/packages/bootloaders.scm (ipxe): Update to 24db39fb2983ca83ab5c6ee37cb57a4f7f6f94e6.

Change-Id: I480fa8efad1e2d72e5239bf7df5fb779179ad96b

---

This fixes a build issue on my aarch64 system with gcc-14.

https://github.com/ipxe/ipxe/commit/7f75d320f

drivers/net/etherfabric.h:524:28: error: ‘reg.u32[0]’ may be used
uninitialized [-Werror=maybe-uninitialized]
---
 gnu/packages/bootloaders.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)


base-commit: d75d1fe6ac7ded7e61322d18b07d347beb609aa0
  

Comments

Vagrant Cascadian Dec. 6, 2024, 8:10 p.m. UTC | #1
On 2024-12-06, Roman Scherer wrote:
> * gnu/packages/bootloaders.scm (ipxe): Update to 24db39fb2983ca83ab5c6ee37cb57a4f7f6f94e6.

This fails to build on aarch64-linux for me, with lots of "unrecognized
command-line option" errors, such as:

gcc: error: unrecognized command-line option ‘-m32’
gcc: error: unrecognized command-line option ‘-malign-double’
gcc: error: unrecognized command-line option ‘-malign-double’
gcc: error: unrecognized command-line option ‘-malign-double’
make[2]: *** [Makefile.housekeeping:979: bin-i386-efi/__moddi3.o] Error 1
make[2]: *** [Makefile.housekeeping:979: bin-i386-efi/__udivmoddi4.o] Error 1
gcc: error: unrecognized command-line option ‘-malign-double’
make[2]: *** [Makefile.housekeeping:979: bin-i386-efi/__udivdi3.o] Error 1
make[2]: *** [Makefile.housekeeping:979: bin-i386-efi/__umoddi3.o] Error 1
make[1]: *** [Makefile.housekeeping:166: bin-i386-efi/ipxe.efi] Error 2
make: *** [Makefile:170: everything] Error 2
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("-j" "6" "ECHO_E_BIN_ECHO=echo" "ECHO_E_BIN_ECHO_E=echo -e" "BUILD_ID_CMD=echo -n 0x8198a1b7" "BUILD_TIMESTAMP=1733491642" "everything") exit-status: 2 term-signal: #f stop-signal: #f>
phase `build' failed after 71.5 seconds
command "make" "-j" "6" "ECHO_E_BIN_ECHO=echo" "ECHO_E_BIN_ECHO_E=echo -e" "BUILD_ID_CMD=echo -n 0x8198a1b7" "BUILD_TIMESTAMP=1733491642" "everything" failed with status 2
build process 8 exited with status 256
builder for `/gnu/store/s60h3s4h3rass2fq6sdkxgs9nf2nhbij-ipxe-1.21.1-3.24db39f.drv' failed with exit code 1
build of /gnu/store/s60h3s4h3rass2fq6sdkxgs9nf2nhbij-ipxe-1.21.1-3.24db39f.drv failed
View build log at '/var/log/guix/drvs/s6/0h3s4h3rass2fq6sdkxgs9nf2nhbij-ipxe-1.21.1-3.24db39f.drv.gz'.
guix build: error: build of `/gnu/store/s60h3s4h3rass2fq6sdkxgs9nf2nhbij-ipxe-1.21.1-3.24db39f.drv' failed


Although I see the same build failures without the patch applied...


live well,
  vagrant
  
Vagrant Cascadian Dec. 6, 2024, 9:05 p.m. UTC | #2
On 2024-12-06, Vagrant Cascadian wrote:
> On 2024-12-06, Roman Scherer wrote:
>> * gnu/packages/bootloaders.scm (ipxe): Update to 24db39fb2983ca83ab5c6ee37cb57a4f7f6f94e6.
>
> This fails to build on aarch64-linux for me, with lots of "unrecognized
> command-line option" errors, such as:
...
> View build log at '/var/log/guix/drvs/s6/0h3s4h3rass2fq6sdkxgs9nf2nhbij-ipxe-1.21.1-3.24db39f.drv.gz'.
> guix build: error: build of `/gnu/store/s60h3s4h3rass2fq6sdkxgs9nf2nhbij-ipxe-1.21.1-3.24db39f.drv' failed
>
>
> Although I see the same build failures without the patch applied...

Ah, but it *does* fix building "ipxe-qemu"! So for that it would be nice
to apply the patch!

We should probably mark "ipxe" as x86_64-linux only; I think it is not
designed to build on other architectures.

That said, this does improve the situation for aarch64, triggering only
about 19 rebuilds... I have yet to finish testing how those rebuilds go,
but it is in progress.

live well,
  vagrant
  
Vagrant Cascadian Dec. 7, 2024, 8:23 a.m. UTC | #3
On 2024-12-06, Roman Scherer wrote:
> * gnu/packages/bootloaders.scm (ipxe): Update to 24db39fb2983ca83ab5c6ee37cb57a4f7f6f94e6.
>
> Change-Id: I480fa8efad1e2d72e5239bf7df5fb779179ad96b

Pushed as c05a9260ccfee4ac008eda928da6463f509a126d.

live well,
  vagrant
  

Patch

diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 61ea74b69a..788c7dc9ef 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -1946,9 +1946,9 @@  (define-public ipxe
   ;;
   ;; TODO: Bump this timestamp at each modifications of the package (not only
   ;; for updates) by running: date +%s.
-  (let ((timestamp "1706118389")
-        (commit "de8a0821c7bc737e724fa3dfb6d89dc36f591d7a")
-        (revision "2"))
+  (let ((timestamp "1733491642")
+        (commit "24db39fb2983ca83ab5c6ee37cb57a4f7f6f94e6")
+        (revision "3"))
     (package
       (name "ipxe")
       (version (git-version "1.21.1" revision commit))
@@ -1960,7 +1960,7 @@  (define-public ipxe
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "0xiffdmf8hpmsw7nm9wp10wd0rs4avm2m3q5ncx0r5zfykannlbd"))))
+                  "0b2h4bsdgnyjna6piwfqqn985vqfjmbz80jh0n7hrnncp2v53qj6"))))
       (build-system gnu-build-system)
       (arguments
        (list