diff mbox series

[bug#72219,33/34] gnu: Add python-looseversion.

Message ID 3f8ba850a4eb6052896ce722eb998c574e55438e.1721514687.git.sharlatanus@gmail.com
State New
Headers show
Series Astronomy update 2024/07 | expand

Commit Message

Sharlatan Hellseher July 20, 2024, 10:40 p.m. UTC
* gnu/packages/python-xyz.scm (python-looseversion): New variable.

Change-Id: I862f10cf5c7285e171335abee429ae76140271dd
---
 gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1ac9884c59..226653cd65 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34534,6 +34534,34 @@  (define-public python-logical-unification
 symbolic expressions in pure Python using the technique of logical unification.")
     (license license:bsd-3)))
 
+(define-public python-looseversion
+  (package
+    (name "python-looseversion")
+    (version "1.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "looseversion" version))
+       (sha256
+        (base32 "17k625ws83lwksa7yyy4mn0i39lmxgrzxihn22l335dvyvrnbppb"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      ;; No tests provided.
+      #:tests? #f))
+    (native-inputs
+     (list python-hatchling))
+    (home-page "https://github.com/effigies/looseversion")
+    (synopsis "Version numbering for anarchists and software realists")
+    (description
+     "This package provides a drop-in replacement for the original
+@code{LooseVersion}.  It implements an identical interface and comparison
+logic to @code{LooseVersion}.  The only major change is that a
+@code{looseversion.LooseVersion} is comparable to a
+@code{distutils.version.LooseVersion}, which means tools should not need to
+worry whether all dependencies that use LooseVersion have migrated.")
+    (license license:psfl)))
+
 (define-public python-cons
   (package
     (name "python-cons")