diff mbox series

[bug#38095] gnu: Add matcha-theme.

Message ID 3f860943566a5c5c59f97b17d6ecf150@posteo.net
State Accepted
Headers show
Series [bug#38095] gnu: Add matcha-theme. | expand

Commit Message

Alexandros Theodotou Nov. 7, 2019, 3:45 p.m. UTC
Moved to gnu/gnome and added missing dependency

 From 2bfdba6c3edb19b52963b288adf0876bfb0faa12 Mon Sep 17 00:00:00 2001
 From: Alexandros Theodotou <alex@zrythm.org>
Date: Thu, 7 Nov 2019 05:37:42 +0000
Subject: [PATCH] gnu: Add matcha-theme.

* gnu/packages/matcha-theme.scm (matcha-theme): New variable.
---
  gnu/packages/gnome.scm | 49 ++++++++++++++++++++++++++++++++++++++++++
  1 file changed, 49 insertions(+)

+   (license license:gpl3)))
+
  (define-public arc-theme
    (package
      (name "arc-theme")
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cd881b5b87..249a6802f0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7105,6 +7105,55 @@  dark elements.  It supports GNOME, Unity, Xfce, 
and Openbox.")
      (home-page "https://numixproject.github.io")
      (license license:gpl3+)))

+(define-public matcha-theme
+  (package
+   (name "matcha-theme")
+   (version "2019-11-02")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append 
"https://github.com/vinceliuice/matcha/archive/" version
+                                ".tar.gz"))
+            (sha256
+             (base32
+              
"0vv16lxrfin187rbn844hfkrg3368in1wmmnygsnag8k2pzhw1a4"))))
+   (build-system trivial-build-system)
+   (outputs '("out"))
+   (arguments
+    '(#:modules ((guix build utils))
+      #:builder
+      (begin
+        (use-modules (guix build utils))
+        (let* ((out (assoc-ref %outputs "out"))
+               (source (assoc-ref %build-inputs "source"))
+               (tar (assoc-ref %build-inputs "tar"))
+               (bash (assoc-ref %build-inputs "bash"))
+               (gzip (assoc-ref %build-inputs "gzip"))
+               (coreutils (assoc-ref %build-inputs "coreutils"))
+               (themesdir (string-append out "/share/themes")))
+          (setenv "PATH" (string-append tar "/bin:"
+                                        (string-append gzip "/bin:")
+                                        (string-append coreutils 
"/bin:")))
+          (invoke "tar" "xf" source)
+          (chdir "matcha-2019-11-02")
+          (substitute* "Install" (("/bin/bash") (string-append bash 
"/bin/bash")))
+          (mkdir-p themesdir)
+          (invoke (string-append bash "/bin/bash") "-c"
+                  (string-append "./Install -d " themesdir))))))
+   (inputs
+    `(("gtk-engines", gtk-engines)))
+   (native-inputs
+    `(("tar", tar)
+      ("bash", bash)
+      ("coreutils", coreutils)
+      ("gzip", gzip)))
+   (synopsis "Flat design theme for GTK 3, GTK 2 and GNOME-Shell")
+   (description
+    "Matcha is a flat Design theme for GTK 3, GTK 2 and Gnome-Shell
+which supports GTK 3 and GTK 2 based desktop environments
+like Gnome, Unity, Budgie, Pantheon, XFCE, Mate and others.")
+   (home-page "https://github.com/vinceliuice/matcha")