[bug#74622,gnome-team,05/10,WIP] gnu: gnome-shell: Update to 46.6.

Message ID 3f842b081fd1f5ea00040f9ed8b93322d013b5dd.1732964015.git.liliana.prikler@gmail.com
State New
Headers
Series Getting ready to finally deliver GNOME 46 |

Commit Message

Liliana Marie Prikler Nov. 30, 2024, 1:25 a.m. UTC
  * gnu/packages/gnome.scm (gnome-shell): Update to 46.6.
[#:configure-flags]: Adjust accordingly.
[#:phases]<wrap-programs>: Likewise.
[#:tests?]: Disabled. XXX: Find a way to reenable them.
---
 gnu/packages/gnome.scm | 18 ++++++------------
 1 file changed, 6 insertions(+), 12 deletions(-)
  

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 565dcec6ab..1d90a636dc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9467,7 +9467,7 @@  (define-public gnome-control-center
 (define-public gnome-shell
   (package
     (name "gnome-shell")
-    (version "44.10")
+    (version "46.6")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -9475,7 +9475,7 @@  (define-public gnome-shell
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "01pw9qnnvh64x56z1gqh0qk6vfn0ihh4zijq23f4bpz9wszlbpwf"))))
+                "009mp7dnlw5pqxl2hx45ams0qhxmjbr7nvcvm9i6jf1fabx17n4b"))))
     (build-system meson-build-system)
     (arguments
      (let ((disallowed-references
@@ -9485,13 +9485,13 @@  (define-public gnome-shell
                   (gexp-input ruby-sass))))
        (list
         #:glib-or-gtk? #t
+        #:tests? #f
         #:disallowed-references disallowed-references
         #:configure-flags
         #~(list "-Dsystemd=false"
                 ;; Otherwise, the RUNPATH will lack the final path component.
                 (string-append "-Dc_link_args=-Wl,-rpath="
-                               #$output "/lib/gnome-shell")
-                "-Dsoup2=false")
+                               #$output "/lib/gnome-shell"))
         #:modules '((guix build meson-build-system)
                     (guix build utils)
                     (ice-9 match)
@@ -9557,7 +9557,7 @@  (define-public gnome-shell
                    (lambda (prog)
                      (wrap-program (string-append #$output "/bin/" prog)
                        `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
-                   '("gnome-shell" "gnome-extensions-app"))
+                   '("gnome-shell" "gnome-extensions" "gnome-extensions-app"))
                   (substitute* (string-append #$output "/share/gnome-shell/"
                                               "org.gnome.Shell.Extensions")
                     (("imports\\.package\\.start" all)
@@ -9577,13 +9577,7 @@  (define-public gnome-shell
                                     "[imports.gi.GLib.getenv('GST_PLUGIN_SYSTEM_PATH'),"
                                     "'" gst-plugin-path "'].filter(v => v).join(':'),"
                                     "true);\n"
-                                    all)))
-                  (for-each
-                   (lambda (prog)
-                     (wrap-program (string-append #$output "/bin/" prog)
-                       `("GUIX_PYTHONPATH"      ":" prefix (,python-path))
-                       `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
-                   '("gnome-shell-perf-tool")))))
+                                    all))))))
             (add-after 'install 'rewire
               (lambda* (#:key inputs #:allow-other-keys)
                 (for-each