diff mbox series

[bug#66107] gnu: routino: Update to 3.4.1.

Message ID 3f7bd68d17e7612af964425d414fcd608800b9e3.1695138908.git.hendursaga@aol.com
State New
Headers show
Series [bug#66107] gnu: routino: Update to 3.4.1. | expand

Commit Message

Hendursaga Sept. 19, 2023, 3:56 p.m. UTC
* gnu/packages/geo.scm (routino): Update to 3.4.1.
[source]: Use HTTPS.
[arguments]: Use G-expressions.
---
 gnu/packages/geo.scm | 67 +++++++++++++++++++++-----------------------
 1 file changed, 32 insertions(+), 35 deletions(-)


base-commit: 15c5f1a2c20b21de0f19f42db1ccab4c42117ebb

Comments

Guillaume Le Vaillant Sept. 21, 2023, 3:40 p.m. UTC | #1
Patch applied as 70fd6721f4921a5ccd0dcf6964458e74636c2c65.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index d702046865..2d0649d174 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2161,43 +2161,40 @@  (define-public python-geoip2
 
 (define-public routino
   (package
-   (name "routino")
-   (version "3.3.3")
-   (source
-    (origin
-     (method url-fetch)
-     (uri (string-append "http://www.routino.org/download/routino-"
-                         version ".tgz"))
-     (sha256
-      (base32 "1xa7l2bjn832nk6bc7b481nv8hd2gj41jwhg0d2qy10lqdvjpn5b"))))
-   (build-system gnu-build-system)
-   (native-inputs
-    (list perl))
-   (inputs
-    (list bzip2 xz zlib))
-   (arguments
-    `(#:test-target "test"
-      #:phases
-      (modify-phases %standard-phases
-        (replace 'configure
-          (lambda* (#:key outputs #:allow-other-keys)
-            (substitute* "Makefile.conf"
-              (("prefix=/usr/local")
-               (string-append "prefix=" (assoc-ref outputs "out")))
-              (("LDFLAGS_LDSO=-Wl,-R\\.")
-               "LDFLAGS_LDSO=-Wl,-R$(libdir)")
-              (("#CFLAGS\\+=-DUSE_XZ")
-               "CFLAGS+=-DUSE_XZ")
-              (("#LDFLAGS\\+=-llzma")
-               "LDFLAGS+=-llzma"))
-            #t)))))
-   (synopsis "Routing application for OpenStreetMap data")
-   (description
-    "Routino is an application for finding a route between two points
+    (name "routino")
+    (version "3.4.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://www.routino.org/download/routino-"
+                                  version ".tgz"))
+              (sha256
+               (base32
+                "0aw5idqz7nv458llgwp5wcgikf34xcblpq46mq7msxfib0m8vahb"))))
+    (build-system gnu-build-system)
+    (native-inputs (list perl))
+    (inputs (list bzip2 xz zlib))
+    (arguments
+     (list #:test-target "test"
+           #:phases #~(modify-phases %standard-phases
+                        (replace 'configure
+                          (lambda* (#:key outputs #:allow-other-keys)
+                            (substitute* "Makefile.conf"
+                              (("prefix=/usr/local")
+                               (string-append "prefix="
+                                              (assoc-ref outputs "out")))
+                              (("LDFLAGS_LDSO=-Wl,-R\\.")
+                               "LDFLAGS_LDSO=-Wl,-R$(libdir)")
+                              (("#CFLAGS\\+=-DUSE_XZ")
+                               "CFLAGS+=-DUSE_XZ")
+                              (("#LDFLAGS\\+=-llzma")
+                               "LDFLAGS+=-llzma")) #t)))))
+    (synopsis "Routing application for OpenStreetMap data")
+    (description
+     "Routino is an application for finding a route between two points
 using the dataset of topographical information collected by
 @url{https://www.OpenStreetMap.org}.")
-   (home-page "https://www.routino.org/")
-   (license license:agpl3+)))
+    (home-page "https://www.routino.org/")
+    (license license:agpl3+)))
 
 (define-public r-rnaturalearthhires
   (let ((commit "c3785a8c44738de6ae8f797080c0a337ebed929d")