diff mbox series

[bug#64905,v3,2/9] gnu: tree-sitter: Update to 0.20.10.

Message ID 3f42d081c13158cfd1c8f4ea6e819778a7f9c92f.1691647854.git.hako@ultrarare.space
State New
Headers show
Series Update tree-sitter{, -{c{, pp, -sharp}, go, java, {java, type}script, python}}, | expand

Commit Message

Hilton Chain Aug. 10, 2023, 6:19 a.m. UTC
* gnu/packages/tree-sitter.scm (tree-sitter): Update to 0.20.10.
(tree-sitter-cli)[arguments]<#:cargo-test-flags>: Skip github_issue_test.
<#:cargo-inputs>: Add rust-path-slash-0.2.
---
 gnu/packages/tree-sitter.scm | 12 ++++++++----
 1 file changed, 8 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index 117c2acb0c..ffed09d945 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -94,18 +94,20 @@  (define-public python-tree-sitter
     (license license:expat)))
 
 (define-public tree-sitter
+  ;; Untagged
+  (let ((commit "0e4ff0bb27edf37b76fc7d35aa768b02cf4392ad"))
   (package
     (name "tree-sitter")
-    (version "0.20.8")
+    (version "0.20.10")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/tree-sitter/tree-sitter")
-                    (commit (string-append "v" version))))
+                    (commit commit)))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "10w17lfn9asqrk612xivkx26lc620s3nnm30hhlyqd4bj19k7gyv"))
+                "1bai4gdhf8w5p1i9np2kl2ms0jq6rgq98qpiipipzayb9jjjlxcy"))
               (modules '((guix build utils)))
               (snippet #~(begin
                            ;; Remove bundled ICU parts
@@ -138,7 +140,7 @@  (define-public tree-sitter
 @end itemize
 
 This package includes the @code{libtree-sitter} runtime library.")
-    (license license:expat)))
+    (license license:expat))))
 
 (define-public tree-sitter-cli
   (package
@@ -173,6 +175,7 @@  (define-public tree-sitter-cli
          ;; good compromise compared to maintaining two different sets of
          ;; grammars (Guix packages vs test fixtures).
          "--skip=tests::corpus_test"
+         "--skip=tests::github_issue_test"
          "--skip=tests::highlight_test"
          "--skip=tests::node_test"
          "--skip=tests::parser_test"
@@ -194,6 +197,7 @@  (define-public tree-sitter-cli
         ("rust-dirs" ,rust-dirs-3)
         ("rust-html-escape" ,rust-html-escape-0.2)
         ("rust-libloading" ,rust-libloading-0.7)
+        ("rust-path-slash" ,rust-path-slash-0.2)
         ("rust-rand" ,rust-rand-0.8)
         ("rust-rustc-hash" ,rust-rustc-hash-1)
         ("rust-semver" ,rust-semver-1)