diff mbox series

[bug#39086,3/5] gnu: Add unicode-cldr-common.

Message ID 3f376d87e5377a04f460f51257780c2988817ec9.camel@student.tugraz.at
State Accepted
Headers show
Series None | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Leo Prikler Jan. 17, 2020, 10:41 a.m. UTC
Am Freitag, den 17.01.2020, 08:41 +0100 schrieb Ricardo Wurmus:
> Leo Prikler <leo.prikler@student.tugraz.at> writes:
> 
> > Am Donnerstag, den 16.01.2020, 22:08 +0100 schrieb Ricardo Wurmus:
> > > Leo Prikler <leo.prikler@student.tugraz.at> writes:
> > > 
> > > > * gnu/packages/ibus (unicode-cldr-commmon): New package.
> > > 
> > > This should be:
> > > 
> > >     * gnu/packages/ibus.scm (unicode-cldr-commmon): New variable.
> > > 
> > > You know, I wonder if these things really belong to ibus.scm.  I
> > > remember a TODO somewhere in the code that bemoaned the lack of
> > > versioned Unicode data files.  Perhaps we should just add a new
> > > module
> > > (gnu packages unicode) — what do you think?
> > I don't mind either way, but these packages don't fix the
> > TODO.  They
> > add yet unseen features.
> 
> That’s okay.  I just think we should start that new unicode.scm
> module
> to finally have a place for these data files.  That would be a more
> appropriate place than ibus.scm.
I agree.  Incidentally, I just coded up a ucd package to use with ibus
or other packages that need the database.  I copied some of the recipe
from the gentoo ebuild, specifically the idea to use the zipped
sources.

Comments

Leo Prikler Feb. 3, 2020, 9:49 a.m. UTC | #1
Bumping this for review.
Ricardo Wurmus Feb. 3, 2020, 3:33 p.m. UTC | #2
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> Bumping this for review.

Sorry for the delay.

I’ve made a few minor changes and pushed the patches to the master
branch (last commit 933bb1acdb).

Thank you!

--
Ricardo
Leo Prikler Feb. 3, 2020, 3:46 p.m. UTC | #3
Am Montag, den 03.02.2020, 16:33 +0100 schrieb Ricardo Wurmus:
> Leo Prikler <leo.prikler@student.tugraz.at> writes:
> 
> > Bumping this for review.
> 
> Sorry for the delay.
> 
> I’ve made a few minor changes and pushed the patches to the master
> branch (last commit 933bb1acdb).
> 
> Thank you!
> 
> --
> Ricardo
Thanks.

With 0001-0005 pushed and the bug marked as done, should I open another
one for 0006-0007, or is there a reason to keep those inputs as they
currently are on master?

Regards,
Leo
Ricardo Wurmus Feb. 3, 2020, 4:06 p.m. UTC | #4
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> Am Freitag, den 17.01.2020, 08:41 +0100 schrieb Ricardo Wurmus:
>> Leo Prikler <leo.prikler@student.tugraz.at> writes:
>>
>> > Am Donnerstag, den 16.01.2020, 22:08 +0100 schrieb Ricardo Wurmus:
>> > > Leo Prikler <leo.prikler@student.tugraz.at> writes:
>> > >
>> > > > * gnu/packages/ibus (unicode-cldr-commmon): New package.
>> > >
>> > > This should be:
>> > >
>> > >     * gnu/packages/ibus.scm (unicode-cldr-commmon): New variable.
>> > >
>> > > You know, I wonder if these things really belong to ibus.scm.  I
>> > > remember a TODO somewhere in the code that bemoaned the lack of
>> > > versioned Unicode data files.  Perhaps we should just add a new
>> > > module
>> > > (gnu packages unicode) — what do you think?
>> > I don't mind either way, but these packages don't fix the
>> > TODO.  They
>> > add yet unseen features.
>>
>> That’s okay.  I just think we should start that new unicode.scm
>> module
>> to finally have a place for these data files.  That would be a more
>> appropriate place than ibus.scm.
> I agree.  Incidentally, I just coded up a ucd package to use with ibus
> or other packages that need the database.  I copied some of the recipe
> from the gentoo ebuild, specifically the idea to use the zipped
> sources.

Thanks, I just pushed those two patches to the master branch (commit
a9e5e6497a).

--
Ricardo
diff mbox series

Patch

From 20c30687c1ae0623232bd8fc41566fe271c5c20a Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Fri, 17 Jan 2020 11:35:24 +0100
Subject: [PATCH 7/7] gnu: Use new ucd package in ibus.

* gnu/packages/ibus.scm (ibus)[native-inputs]: Add ucd.
Remove unicode-nameslist and unicode-blocks.
(arguments)[configure-flags]: Update accordingly.
(phases)<prepare-ucd-dir>: Remove phase.
---
 gnu/packages/ibus.scm | 24 +++---------------------
 1 file changed, 3 insertions(+), 21 deletions(-)

diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 16dfbf4888..c0766c06bd 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -82,16 +82,11 @@ 
                                 (assoc-ref %build-inputs "unicode-cldr-common")
                                 "/share/unicode/cldr/common/annotations")
                                (string-append "--with-ucd-dir="
-                                              (getcwd) "/ucd")
+                                              (assoc-ref %build-inputs "ucd")
+                                              "/share/ucd")
                                "--enable-wayland")
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'prepare-ucd-dir
-           (lambda* (#:key inputs #:allow-other-keys)
-             (mkdir-p "../ucd")
-             (symlink (assoc-ref inputs "unicode-blocks") "../ucd/Blocks.txt")
-             (symlink (assoc-ref inputs "unicode-nameslist") "../ucd/NamesList.txt")
-             #t))
          (add-after 'unpack 'patch-python-target-directories
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((root (string-append (assoc-ref outputs "out")
@@ -158,22 +153,9 @@ 
     (native-inputs
      `(("glib" ,glib "bin") ; for glib-genmarshal
        ("gobject-introspection" ,gobject-introspection) ; for g-ir-compiler
-
+       ("ucd" ,ucd)
        ("unicode-emoji" ,unicode-emoji)
        ("unicode-cldr-common" ,unicode-cldr-common)
-       ;; XXX TODO: Move Unicode data to its own (versioned) package.
-       ("unicode-nameslist"
-        ,(origin
-           (method url-fetch)
-           (uri "https://www.unicode.org/Public/12.0.0/ucd/NamesList.txt")
-           (sha256
-            (base32 "0vsq8gx7hws8mvxy3nlglpwxw7ky57q0fs09d7w9xgb2ylk7fz61"))))
-       ("unicode-blocks"
-        ,(origin
-           (method url-fetch)
-           (uri "https://www.unicode.org/Public/12.0.0/ucd/Blocks.txt")
-           (sha256
-            (base32 "041sk54v6rjzb23b9x7yjdwzdp2wc7gvfz7ybavgg4gbh51wm8x1"))))
        ("vala" ,vala)
        ("pkg-config" ,pkg-config)))
     (native-search-paths
-- 
2.25.0