diff mbox series

[bug#37535] gnu: Add python-flask-cors.

Message ID 3f1fdf71-c664-4fb1-8ba1-f82e2d5f39b7@www.fastmail.com
State Accepted
Headers show
Series [bug#37535] gnu: Add python-flask-cors. | expand

Commit Message

Hamzeh Nasajpour Sept. 27, 2019, 10:16 p.m. UTC
* gnu/packages/python-web.scm (python-flask-cors): New variable.
---
 gnu/packages/python-web.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Ludovic Courtès Sept. 28, 2019, 8:40 p.m. UTC | #1
Hi Hamzeh,

"Hamzeh Nasajpour" <h.nasajpour@pantherx.org> skribis:

> * gnu/packages/python-web.scm (python-flask-cors): New variable.

[...]

> +(define-public python-flask-cors
> +  (package
> +  (name "python-flask-cors")
> +    (version "3.0.7")

The indentation is different from what we usually do.  Could you run
./etc/indent-code.el as noted at
<https://guix.gnu.org/manual/en/html_node/Formatting-Code.html>?

> +    (arguments
> +      `(#:tests? #f))

Could you try to run the test suite or, as a last resort, add a comment
explaining why it is disabled?

> +    (home-page "https://github.com/corydolphin/flask-cors")
> +    (synopsis "A Flask extension adding a decorator for CORS support")
> +    (description
> +     "A Flask extension for handling Cross Origin Resource Sharing (CORS), 
> +making cross-origin AJAX possible.")

Please fix the issue reported by ‘guix lint’ for the synopsis and make a
full sentence for the description.  See
<https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html>.

Could you send an updated patch?

Thanks,
Ludo’.
Ludovic Courtès Oct. 6, 2019, 12:36 p.m. UTC | #2
Ping!  :-)

Ludovic Courtès <ludo@gnu.org> skribis:

> Hi Hamzeh,
>
> "Hamzeh Nasajpour" <h.nasajpour@pantherx.org> skribis:
>
>> * gnu/packages/python-web.scm (python-flask-cors): New variable.
>
> [...]
>
>> +(define-public python-flask-cors
>> +  (package
>> +  (name "python-flask-cors")
>> +    (version "3.0.7")
>
> The indentation is different from what we usually do.  Could you run
> ./etc/indent-code.el as noted at
> <https://guix.gnu.org/manual/en/html_node/Formatting-Code.html>?
>
>> +    (arguments
>> +      `(#:tests? #f))
>
> Could you try to run the test suite or, as a last resort, add a comment
> explaining why it is disabled?
>
>> +    (home-page "https://github.com/corydolphin/flask-cors")
>> +    (synopsis "A Flask extension adding a decorator for CORS support")
>> +    (description
>> +     "A Flask extension for handling Cross Origin Resource Sharing (CORS), 
>> +making cross-origin AJAX possible.")
>
> Please fix the issue reported by ‘guix lint’ for the synopsis and make a
> full sentence for the description.  See
> <https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html>.
>
> Could you send an updated patch?
>
> Thanks,
> Ludo’.
Jelle Licht May 28, 2023, 9:34 p.m. UTC | #3
python-flask-cors is available on current guix master, so closing this.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e37ae94e18..276ed0f01f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2146,6 +2146,27 @@  SlimIt also provides a library that includes a JavaScript parser, lexer,
 pretty printer and a tree visitor.")
     (license license:expat)))
 
+(define-public python-flask-cors
+  (package
+  (name "python-flask-cors")
+    (version "3.0.7")
+    (source (origin
+      (method url-fetch)
+      (uri (pypi-uri "Flask-Cors" version))
+      (sha256 (base32 "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))
+    (build-system python-build-system)
+    (arguments
+      `(#:tests? #f))
+    (propagated-inputs
+      `(("python-six" ,python-six)
+        ("python-flask" ,python-flask)))
+    (home-page "https://github.com/corydolphin/flask-cors")
+    (synopsis "A Flask extension adding a decorator for CORS support")
+    (description
+     "A Flask extension for handling Cross Origin Resource Sharing (CORS), 
+making cross-origin AJAX possible.")
+    (license license:expat)))
+
 (define-public python-flask-restful
   (package
     (name "python-flask-restful")