diff mbox series

[bug#72144,1/2] gnu: Add python-property-cached.

Message ID 3ef79164bb4520b45043f7e7f0410de79c3b0283.1721163251.git.monego@posteo.net
State New
Headers show
Series Add python-lcapy | expand

Commit Message

Vinicius Monego July 16, 2024, 11:38 p.m. UTC
* gnu/packages/python-xyz.scm (python-property-cached): New variable.

Change-Id: I173c358bd8cf6d536cc984c3d9c76e0bad41dad4
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

jgart July 17, 2024, 1:57 a.m. UTC | #1
Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 88f19c0f55..2a13097e8b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10011,6 +10011,28 @@  (define-public python-olefile
 the OleFileIO module from PIL, the Python Image Library.")
     (license license:bsd-3)))
 
+(define-public python-property-cached
+  (package
+    (name "python-property-cached")
+    (version "1.6.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "property-cached" version ".zip"))
+       (sha256
+        (base32 "0wxv5sdx1p7ils36j6j6hfscz8v2vzbq212i8y8r0lrnxpqlx71y"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      ;; AssertionError.
+      #:test-flags #~(list "-k" "not test_threads_ttl_expiry")))
+    (native-inputs (list python-freezegun python-pytest unzip))
+    (home-page "https://github.com/althonos/property-cached/")
+    (synopsis "Decorator for caching properties in classes")
+    (description "This package provides a decorator for caching properties in
+classes.  It is forked from @code{cached-property}.")
+    (license license:bsd-3)))
+
 (define-public python-pypdf3
   (package
     (name "python-pypdf3")