diff mbox series

[bug#73818,2/2] gnu: prrte: Remove reference to GCC and other build tools.

Message ID 3eed0df2217e206b04619ded2debc38213e312ac.1728996088.git.ludo@gnu.org
State New
Headers show
Series Reduce size of openmpi@5 closure | expand

Commit Message

Ludovic Courtès Oct. 15, 2024, 12:45 p.m. UTC
From: Ludovic Courtès <ludovic.courtes@inria.fr>

This reduces the closure of ‘prrte’ from 305 MiB to 99 MiB.

* gnu/packages/parallel.scm (prrte)[arguments]: Add #:phases.

Change-Id: Idc26cf5899dd5fa8378535fc8530dbdb3e20608d
---
 gnu/packages/parallel.scm | 22 +++++++++++++++++++---
 1 file changed, 19 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index fc96136065..186aebad45 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -711,9 +711,25 @@  (define-public prrte
               "0wiy0vk37v4db1jgxza8bci0cczcvj34dalzsrlz05dk45zb7dl3"))))
    (build-system gnu-build-system)
    (arguments
-    (list #:configure-flags #~(list (string-append "--with-hwloc="
-                                                   (assoc-ref %build-inputs "hwloc"))
-                                    (string-append "--with-pmix=" #$(this-package-input "openpmix")))))
+    (list #:configure-flags
+          #~(list (string-append "--with-hwloc="
+                                 (assoc-ref %build-inputs "hwloc"))
+                  (string-append "--with-pmix="
+                                 #$(this-package-input "openpmix")))
+
+          #:phases
+          #~(modify-phases %standard-phases
+              (add-after 'unpack 'remove-absolute-references
+                (lambda _
+                  ;; Remove references to GCC, the shell, etc. (shown by
+                  ;; 'prte_info') to reduce the closure size.
+                  (substitute* "src/tools/prte_info/param.c"
+                    (("_ABSOLUTE")
+                     "")
+                    (("PRTE_CONFIGURE_CLI")
+                     "\"[elided to reduce closure]\"")))))
+
+          #:disallowed-references (list (canonical-package gcc))))
    (inputs (list libevent
                  `(,hwloc "lib")
                  openpmix))