[bug#76746,v2,10/13] gnu: Add python-ytmusicapi.
Commit Message
* gnu/packages/python-web.scm (python-ytmusicapi): New variable.
Change-Id: I97f4ea045f0ebb82cc2690d71a126988367e273d
---
gnu/packages/python-web.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
@@ -10745,6 +10745,32 @@ (define-public python-soundcloud-v2
only methods). Does not require an API key.")
(license license:expat)))
+(define-public python-ytmusicapi
+ (package
+ (name "python-ytmusicapi")
+ (version "1.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ytmusicapi" version))
+ (sha256
+ (base32 "1yb95pv3jxbmg43lv92ll6741nzlsksixxlnggs6prqn352qa9l1"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
+ (propagated-inputs (list python-requests))
+ (arguments
+ '(#:tests? #f)) ;tests require network
+ (home-page "https://github.com/sigma67/ytmusicapi")
+ (synopsis "Python 3 library for the YouTube Music API")
+ (description
+ "This is a Python 3 library to send requests to the YouTube Music API. It
+emulates YouTube Music web client requests using the user’s cookie data for
+authentication.")
+ (license license:expat)))
+
(define-public python-whatthepatch
(package
(name "python-whatthepatch")