diff mbox series

[bug#63566] gnu: add tcptrack

Message ID 3e95e1934550698a5ce8b2395ac591df6c5fe9b3.1684348522.git.jakob.kirsch@web.de
State New
Headers show
Series [bug#63566] gnu: add tcptrack | expand

Commit Message

Jakob Kirsch May 17, 2023, 6:35 p.m. UTC
---
 gnu/packages/admin.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: c8e599b9391f789a8a3e2183fc8f0c2a5061ceb0
--
2.39.2

Comments

Jelle Licht June 20, 2023, 8:29 p.m. UTC | #1
Hi Jakob,

Thank you for the patch! Delayed as it may be, I have some small points
of order to share.

We try to follow the Changelog format in commit logs, see
https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html
for the thorough explanation (or just have a look at commit logs for
some of the other packages that were added by people).

Jakob Kirsch <jakob.kirsch@web.de> writes:
> ---
>  gnu/packages/admin.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
> index 047b0ebcc6..0ae883e0b4 100644
> --- a/gnu/packages/admin.scm
> +++ b/gnu/packages/admin.scm
> @@ -4255,6 +4255,30 @@ (define-public thermald
>      (supported-systems '("i686-linux" "x86_64-linux"))
>      (license license:gpl2)))
>
> +(define-public tcptrack
> +  (package
> +    (name "tcptrack")
> +    (version "1.4.3")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/bchretien/tcptrack")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "08lh3l67wn4kq9q0nfspc7rj0jvp9dzwjgxpvqliwcif8cy5mi45"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:tests? #f))
Please add a comment explaining why tests are disabled (e.g. `; no
tests')

> +    (inputs (list libpcap ncurses))
> +    (synopsis "Display information about TCP connections")
> +    (description
> +     "A sniffer which displays information about TCP connections it
> +sees on a network interface. (backup from Steve Bensons's tcptrack)")

The description should contain complete sentences, if possible.
How about something like this:

Tcptrack is a sniffer which displays information about TCP connections
it sees on a network interface.  This is a fork of Steve Benson’s
tcptrack.

(Note the double spacing after the .)

> +    (home-page "https://github.com/bchretien/tcptrack")
> +    (license license:lgpl2.1)))

Having looked at the source archives, I think there are a bunch of
GPLv2+ licensed source files in the tarball (note the missing L). Could
you perhaps open an issue so the author(s) could (re)confirm the status
of these source files? The folks over at [1] also indicate the package
is licensed as GPLv2+, so there may be some confusion about the
licensing status of the package.

Cheers,
 Jelle

[1]: https://directory.fsf.org/wiki/Tcptrack#tab=Overview
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 047b0ebcc6..0ae883e0b4 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4255,6 +4255,30 @@  (define-public thermald
     (supported-systems '("i686-linux" "x86_64-linux"))
     (license license:gpl2)))

+(define-public tcptrack
+  (package
+    (name "tcptrack")
+    (version "1.4.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/bchretien/tcptrack")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "08lh3l67wn4kq9q0nfspc7rj0jvp9dzwjgxpvqliwcif8cy5mi45"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f))
+    (inputs (list libpcap ncurses))
+    (synopsis "Display information about TCP connections")
+    (description
+     "A sniffer which displays information about TCP connections it
+sees on a network interface. (backup from Steve Bensons's tcptrack)")
+    (home-page "https://github.com/bchretien/tcptrack")
+    (license license:lgpl2.1)))
+
 (define-public masscan
   (package
     (name "masscan")