diff mbox series

[bug#66043,2/2] gnu: bcachefs-tools: Restyle format.

Message ID 3e7fa3295d876267df6babbb9a6578a4891822b2.1694931512.git.a.r.draidi@redscript.org
State New
Headers show
Series Update bcachefs-tools to 1.2 and restyle package | expand

Commit Message

Ahmad Draidi Sept. 17, 2023, 6:38 a.m. UTC
* gnu/packages/file-systems.scm (bcachefs-tools): Reformat with 'guix style'
and manually break some long lines.
---
 gnu/packages/file-systems.scm | 163 ++++++++++++++++++----------------
 1 file changed, 84 insertions(+), 79 deletions(-)

Comments

Tobias Geerinckx-Rice Sept. 26, 2023, 9:41 p.m. UTC | #1
Hi!

Thanks for taking care of the bcachefs-tools package!

> Who else is excited for bcachefs being merged upstream soon? :)

/me raises hand.  Four years of sometimes-painful rebases will not be 
missed.

On 2023-09-17 8:38, Ahmad Draidi via Guix-patches via wrote:
> * gnu/packages/file-systems.scm (bcachefs-tools): Reformat with 'guix 
> style'
> and manually break some long lines.

I don't think ‘guix style’ improved things anywhere, but hunks like

-       (list #:make-flags
-             #~(list (string-append "VERSION=" #$version) ; ‘v…-nogit’ 
otherwise
-                     (string-append "PREFIX=" #$output)
-                     "INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
-                     (string-append "CC=" #$(cc-for-target))
-                     (string-append "PKG_CONFIG=" 
#$(pkg-config-for-target))
-                     ;; ‘This will be less of an option in the future, 
as more
-                     ;; code gets rewritten in Rust.’
-                     "NO_RUST=better")
+     (list #:make-flags #~(list (string-append "VERSION="
+                                               #$version) ;‘v…-nogit’ 
otherwise
+                           (string-append "PREFIX="
+                                          #$output)
+                           
"INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
+                           (string-append "CC="
+                                          #$(cc-for-target))
+                           (string-append "PKG_CONFIG="
+                                          #$(pkg-config-for-target))
+                           ;; ‘This will be less of an option in the 
future, as more
+                           ;; code gets rewritten in Rust.’
+                           "NO_RUST=better")

are particularly regressive.

This is of course not your fault at all and should be fixed in ‘guix 
style’, but I do intend on reverting this change when I upgrade 
bcachefs-tools to the next git snapshot ;-)

Bcachefs is still improving fast enough that I think it's okay to 
package snapshots, at least until 6.7 lands.  Using outdated tools on a 
newer kernel generally fails outright, and once corrupted my file 
system.

Kind regards,

T G-R

Sent from a Web browser.  Excuse or enjoy my brevity.
A Sept. 29, 2023, 4:29 p.m. UTC | #2
Hello Tobias,

On 27 September 2023 01:41:07 GMT+04:00, Tobias Geerinckx-Rice <me@tobias.gr> wrote:
>Hi!
>
>Thanks for taking care of the bcachefs-tools package!
>
>> Who else is excited for bcachefs being merged upstream soon? :)
>
>/me raises hand.  Four years of sometimes-painful rebases will not be missed.

I find it reassuring that a Guix maintainer is a long time bcachefs user. :)

>
>On 2023-09-17 8:38, Ahmad Draidi via Guix-patches via wrote:
>> * gnu/packages/file-systems.scm (bcachefs-tools): Reformat with 'guix style'
>> and manually break some long lines.
>
>I don't think ‘guix style’ improved things anywhere, but hunks like
>
>-       (list #:make-flags
>-             #~(list (string-append "VERSION=" #$version) ; ‘v…-nogit’ otherwise
>-                     (string-append "PREFIX=" #$output)
>-                     "INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
>-                     (string-append "CC=" #$(cc-for-target))
>-                     (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
>-                     ;; ‘This will be less of an option in the future, as more
>-                     ;; code gets rewritten in Rust.’
>-                     "NO_RUST=better")
>+     (list #:make-flags #~(list (string-append "VERSION="
>+                                               #$version) ;‘v…-nogit’ otherwise
>+                           (string-append "PREFIX="
>+                                          #$output)
>+                           "INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
>+                           (string-append "CC="
>+                                          #$(cc-for-target))
>+                           (string-append "PKG_CONFIG="
>+                                          #$(pkg-config-for-target))
>+                           ;; ‘This will be less of an option in the future, as more
>+                           ;; code gets rewritten in Rust.’
>+                           "NO_RUST=better")
>
>are particularly regressive.
>
>This is of course not your fault at all and should be fixed in ‘guix style’, but I do intend on reverting this change when I upgrade bcachefs-tools to the next git snapshot ;-)

I had to remove the extra indentation caused by the parentheses, while keeping as much of my opinion out of styling as possible. It doesn't help with my OCD that the Guix patch submission checklist asks to run 'guix style'. :D

Perhaps I should look at 'guix style' code sometime.

>
>Bcachefs is still improving fast enough that I think it's okay to package snapshots, at least until 6.7 lands.  Using outdated tools on a newer kernel generally fails outright, and once corrupted my file system.
>
>Kind regards,
>
>T G-R


Thanks, and keep up the great work!

>
>Sent from a Web browser.  Excuse or enjoy my brevity.
diff mbox series

Patch

diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index efa26a199a..58fb1b5363 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -575,84 +575,89 @@  (define-public gphotofs
     (license license:gpl2+)))
 
 (define-public bcachefs-tools
-    (package
-      (name "bcachefs-tools")
-      (version "1.2")
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://evilpiepirate.org/git/bcachefs-tools.git")
-               (commit (string-append "v" version))))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "0wgqclkkdkqis3aq6wp0kcn1bsynybm3dnpcf7vlcvx85kdmcxg8"))))
-      (build-system gnu-build-system)
-      (arguments
-       (list #:make-flags
-             #~(list (string-append "VERSION=" #$version) ; ‘v…-nogit’ otherwise
-                     (string-append "PREFIX=" #$output)
-                     "INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
-                     (string-append "CC=" #$(cc-for-target))
-                     (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
-                     ;; ‘This will be less of an option in the future, as more
-                     ;; code gets rewritten in Rust.’
-                     "NO_RUST=better")
-             #:phases
-             #~(modify-phases %standard-phases
-                 (delete 'configure)    ; no configure script
-                 (replace 'check
-                   ;; The test suite is moribund upstream (‘never been useful’),
-                   ;; but let's keep running it as a sanity check until then.
-                   (lambda* (#:key tests? make-flags #:allow-other-keys)
-                     (when tests?
-                       ;; We must manually build the test_helper first.
-                       (apply invoke "make" "tests" make-flags)
-                       (invoke (string-append
-                                #$(this-package-native-input "python-pytest")
-                                "/bin/pytest") "-k"
-                                ;; These fail (‘invalid argument’) on kernels
-                                ;; with a previous bcachefs version.
-                                (string-append "not test_format and "
-                                               "not test_fsck and "
-                                               "not test_list and "
-                                               "not test_list_inodes and "
-                                               "not test_list_dirent")))))
-                 (add-after 'install 'patch-shell-wrappers
-                   ;; These are overcomplicated wrappers that invoke readlink(1)
-                   ;; to exec the appropriate bcachefs(8) subcommand.  We can
-                   ;; simply patch in the latter file name directly, and do.
-                   (lambda _
-                     (let ((sbin/ (string-append #$output "/sbin/")))
-                       (substitute* (find-files sbin/ (lambda (file stat)
-                                                        (not (elf-file? file))))
-                         (("SDIR=.*") "")
-                         (("\\$\\{SDIR.*}/") sbin/))))))))
-      (native-inputs
-       (cons* pkg-config
-              ;; For generating documentation with rst2man.
-              python
-              python-docutils
-              ;; For tests.
-              python-pytest
-              (if (member (%current-system) (package-supported-systems valgrind))
-                  (list valgrind)
-                  '())))
-      (inputs
-       (list eudev
-             keyutils
-             libaio
-             libscrypt
-             libsodium
-             liburcu
-             `(,util-linux "lib")
-             lz4
-             zlib
-             `(,zstd "lib")))
-      (home-page "https://bcachefs.org/")
-      (synopsis "Tools to create and manage bcachefs file systems")
-      (description
-       "The bcachefs-tools are command-line utilities for creating, checking,
+  (package
+    (name "bcachefs-tools")
+    (version "1.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://evilpiepirate.org/git/bcachefs-tools.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0wgqclkkdkqis3aq6wp0kcn1bsynybm3dnpcf7vlcvx85kdmcxg8"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:make-flags #~(list (string-append "VERSION="
+                                               #$version) ;‘v…-nogit’ otherwise
+                           (string-append "PREFIX="
+                                          #$output)
+                           "INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
+                           (string-append "CC="
+                                          #$(cc-for-target))
+                           (string-append "PKG_CONFIG="
+                                          #$(pkg-config-for-target))
+                           ;; ‘This will be less of an option in the future, as more
+                           ;; code gets rewritten in Rust.’
+                           "NO_RUST=better")
+           #:phases #~(modify-phases %standard-phases
+                        (delete 'configure) ;no configure script
+                        (replace 'check
+                          ;; The test suite is moribund upstream (‘never been
+                          ;; useful’), but let's keep running it as a sanity
+                          ;; check until then.
+                          (lambda* (#:key tests? make-flags #:allow-other-keys)
+                            (when tests?
+                              ;; We must manually build the test_helper first.
+                              (apply invoke "make" "tests" make-flags)
+                              (invoke (string-append #$(this-package-native-input
+                                                        "python-pytest")
+                                                     "/bin/pytest") "-k"
+                                      ;; These fail (‘invalid argument’) on kernels
+                                      ;; with a previous bcachefs version.
+                                      (string-append "not test_format and "
+                                       "not test_fsck and "
+                                       "not test_list and "
+                                       "not test_list_inodes and "
+                                       "not test_list_dirent")))))
+                        (add-after 'install 'patch-shell-wrappers
+                          ;; These are overcomplicated wrappers that invoke readlink(1)
+                          ;; to exec the appropriate bcachefs(8) subcommand.  We can
+                          ;; simply patch in the latter file name directly, and do.
+                          (lambda _
+                            (let ((sbin/ (string-append #$output "/sbin/")))
+                              (substitute* (find-files sbin/
+                                                       (lambda (file stat)
+                                                         (not (elf-file? file))))
+                                (("SDIR=.*")
+                                 "")
+                                (("\\$\\{SDIR.*}/")
+                                 sbin/))))))))
+    (native-inputs (cons* pkg-config
+                          ;; For generating documentation with rst2man.
+                          python
+                          python-docutils
+                          ;; For tests.
+                          python-pytest
+                          (if (member (%current-system)
+                                      (package-supported-systems valgrind))
+                              (list valgrind)
+                              '())))
+    (inputs (list eudev
+                  keyutils
+                  libaio
+                  libscrypt
+                  libsodium
+                  liburcu
+                  `(,util-linux "lib")
+                  lz4
+                  zlib
+                  `(,zstd "lib")))
+    (home-page "https://bcachefs.org/")
+    (synopsis "Tools to create and manage bcachefs file systems")
+    (description
+     "The bcachefs-tools are command-line utilities for creating, checking,
 and otherwise managing bcachefs file systems.
 
 Bcachefs is a @acronym{CoW, copy-on-write} file system supporting native
@@ -662,7 +667,7 @@  (define-public bcachefs-tools
 In addition, bcachefs provides all the functionality of bcache, a block-layer
 caching system, and lets you assign different roles to each device based on its
 performance and other characteristics.")
-      (license license:gpl2+)))
+    (license license:gpl2+)))
 
 (define-public bcachefs-tools/static
   (package