diff mbox series

[bug#63038,1/5] gnu: httpd: Update to 2.4.57 [security fixes].

Message ID 3ddfb053e7baefefe88c560a41096d2e2aa7ed69.1682269908.git.leo@famulari.name
State New
Headers show
Series [bug#63038,1/5] gnu: httpd: Update to 2.4.57 [security fixes]. | expand

Commit Message

Leo Famulari April 23, 2023, 5:11 p.m. UTC
Fixes CVE-2023-27522, CVE-2023-25690, CVE-2022-37436, CVE-2022-36760,
CVE-2006-20001, CVE-2022-31813, CVE-2022-30556, CVE-2022-30522,
CVE-2022-29404, CVE-2022-28615, CVE-2022-28614, CVE-2022-28330,
CVE-2022-26377, CVE-2022-23943, CVE-2022-22721, CVE-2022-22720,
and CVE-2022-22719.

* gnu/packages/web.scm (httpd): Update to 2.4.57.
(httpd/pinned): New variable.
* gnu/packages/gnome.scm (libsoup-minimal): Replace httpd with httpd/pinned.
---
 gnu/packages/gnome.scm |  2 +-
 gnu/packages/web.scm   | 19 +++++++++++++++++--
 2 files changed, 18 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2cb087c987..49c678b2eb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5241,7 +5241,7 @@  (define-public libsoup-minimal
            vala
            curl
            gnutls ;for 'certtool'
-           httpd))
+           httpd/pinned))
     (propagated-inputs
      ;; libsoup-3.0.pc refers to all of these (except where otherwise noted)
      (list brotli
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6fa3067bbe..c8a1d0123e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -273,14 +273,14 @@  (define-public qhttp
 (define-public httpd
   (package
     (name "httpd")
-    (version "2.4.52")
+    (version "2.4.57")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://apache/httpd/httpd-"
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "1jgmfbazc2n9dnl7axhahwppyq25bvbvwx0lqplq76by97fgf9q1"))))
+               "0ajdz5f2w9nbmqydip2mv9m4xlnc4swmw7mqzgnrbq4mxr5bik6v"))))
     (build-system gnu-build-system)
     (native-inputs (list `(,pcre "bin")))       ;for 'pcre-config'
     (inputs (list apr apr-util openssl perl)) ; needed to run bin/apxs
@@ -305,6 +305,21 @@  (define-public httpd
     (license license:asl2.0)
     (home-page "https://httpd.apache.org/")))
 
+;; A package variant that may be out of date and vulnerable. Only for use in
+;; test suites and should never be referred to by a built package.
+(define-public httpd/pinned
+  (hidden-package
+    (package
+      (inherit httpd)
+      (version "2.4.52")
+      (source (origin
+               (method url-fetch)
+               (uri (string-append "mirror://apache/httpd/httpd-"
+                                   version ".tar.bz2"))
+               (sha256
+                (base32
+                 "1jgmfbazc2n9dnl7axhahwppyq25bvbvwx0lqplq76by97fgf9q1")))))))
+
 (define-public mod-wsgi
   (package
     (name "mod-wsgi")