[bug#77391,v5,4/4] gnu: emacs-ellama: Enable tests.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-ellama)[arguments]: Enable tests; skip
failing.
Change-Id: I1b468c7b30ad35ae553d354ef63da2d4d1c056a7
---
gnu/packages/emacs-xyz.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)
@@ -5789,6 +5789,19 @@ (define-public emacs-ellama
(sha256 (base32
"1019vwrm95ck2gi29mvwd7sy753zgwa3addw2x0qbhvb3r53620v"))))
(build-system emacs-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (substitute* (find-files "tests/" "\\.el$")
+ (("\\(ert-deftest test-ellama-context-element-extract-info-node .*" all)
+ (string-append all "(skip-unless nil)\n"))))))
+ #:tests? #t
+ #:test-command #~(list "emacs" "-Q" "--batch"
+ "-l" "ellama.el"
+ "-l" "tests/test-ellama.el"
+ "-f" "ert-run-tests-batch-and-exit")))
(propagated-inputs (list emacs-compat emacs-llm emacs-plz emacs-transient))
(home-page "https://github.com/s-kostyaev/ellama")
(synopsis "Tool for interacting with LLMs")