diff mbox series

[bug#40470] gnu: Add tap-lv2.

Message ID 3ddca5393440447967d0f17b022577c8265d440c.camel@zrythm.org
State Accepted
Headers show
Series [bug#40470] gnu: Add tap-lv2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou April 6, 2020, 3:04 p.m. UTC
Hi,

This patch adds tap-lv2, an LV2 port of the TAP LADSPA plugins. I used
the date as a version because there was no tag.

Thanks,
Alex

Comments

Leo Famulari April 6, 2020, 7:02 p.m. UTC | #1
On Mon, Apr 06, 2020 at 04:04:49PM +0100, Alexandros Theodotou wrote:
> Hi,
> 
> This patch adds tap-lv2, an LV2 port of the TAP LADSPA plugins. I used
> the date as a version because there was no tag.

Can you revise the version number stuff based on the guidelines in the
manual section Version Numbers?

https://guix.gnu.org/manual/en/html_node/Version-Numbers.html#Version-Numbers

Otherwise LGTM
diff mbox series

Patch

From ce383ce1bffefbd41434de97d1756516b9546450 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Mon, 6 Apr 2020 16:02:46 +0100
Subject: [PATCH] gnu: Add tap-lv2.

* gnu/packages/music.scm (tap-lv2): new variable.
---
 gnu/packages/music.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ee402bad4d..429719bb2d 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5380,3 +5380,43 @@  filtered, pitch shifted and ultimately disintegrated.  This is an unofficial
 port of the Regrader plugin created by Igorski.  It is available as an LV2
 plugin and a standalone JACK application.")
     (license license:expat)))
+
+(define-public tap-lv2
+  (package
+    (name "tap-lv2")
+    (version "0.0.0-20200406")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/moddevices/tap-lv2.git")
+               (commit "cab6e0dfb2ce20e4ad34b067d1281ec0b193598a")))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "0q480djfqd9g8mzrggc4vl7yclrhdjqx563ghs8mvi2qq8liycw3"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ; no check target
+       #:make-flags
+       (list "CC=gcc")
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure) ; no configure
+         (replace 'install
+           (lambda _
+             (invoke "make"
+             (string-append "INSTALL_PATH="
+                            (assoc-ref %outputs "out")
+                            "/lib/lv2")
+                     "install"))))))
+    (inputs
+      `(("lv2", lv2)))
+    (native-inputs
+      `(("pkg-config", pkg-config)))
+    (synopsis "Audio plugin collection")
+    (description "TAP (Tom's Audio Processing) plugins is a collection of
+audio effect plugins originally released as LADSPA plugins.  This package
+offers an LV2 version ported by moddevices.")
+    (home-page "http://tap-plugins.sf.net/")
+    (license license:gpl2)))
-- 
2.26.0