diff mbox series

[bug#61664] gnu: Add tofi.

Message ID 3dd4753a-1e1c-0a0b-1c95-cc8caa74c97b@gorski.stream
State New
Headers show
Series [bug#61664] gnu: Add tofi. | expand

Commit Message

Yovan Naumovski Feb. 20, 2023, 9:39 p.m. UTC
Hi,

here is a patch that adds the "tofi" package, an application launcher 
for Wayland.

Best regards,

Yovan.

Comments

Nicolas Goaziou Feb. 24, 2023, 11:29 a.m. UTC | #1
Hello,

Yovan Naumovski via Guix-patches via <guix-patches@gnu.org> writes:

> +(define-public tofi

Applied with a proper commit message. Thanks.

> +    (description
> +     "Simple @command{dmenu}/@command{rofi} replacement for wlroots-based
> +Wayland compositors such as Sway.")

I also turned the description into a full sentence.

Regards,
diff mbox series

Patch

From b33ae1cde5e4b03f31bc722f9eafe7b79a2677c1 Mon Sep 17 00:00:00 2001
From: Yovan Naumovski <yovan@gorski.stream>
Date: Mon, 20 Feb 2023 23:35:18 +0200
Subject: [PATCH] gnu: Add tofi.

---
 gnu/packages/xdisorg.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index ddb70bd817..df84815f9b 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1980,6 +1980,36 @@  (define-public tint2
 actions, a built-in clock, a battery monitor and a system tray.")
     (license license:gpl2)))
 
+(define-public tofi
+  (package
+    (name "tofi")
+    (version "0.8.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/philj56/tofi")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "11bfi9his0cc5mzikamr5icv5mh2fyj9jy5l3sbbayj6jk51f68y"))))
+    (build-system meson-build-system)
+    (arguments
+     (list #:meson meson-0.63)) ;requires meson 0.61 or later
+    (native-inputs (list pkg-config))
+    (inputs (list cairo
+                  harfbuzz
+                  libxkbcommon
+                  pango
+                  wayland
+                  wayland-protocols))
+    (home-page "https://github.com/philj56/tofi")
+    (synopsis "Application launcher for Wayland")
+    (description
+     "Simple @command{dmenu}/@command{rofi} replacement for wlroots-based
+Wayland compositors such as Sway.")
+    (license license:expat)))
+
 (define-public dzen
   (let ((commit "488ab66019f475e35e067646621827c18a879ba1")
         (revision "1"))
-- 
2.39.1