From 84354284df02d7bb254f4dfe453b11ba19d43ebd Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Wed, 8 Jan 2020 08:26:55 -0500
Subject: [PATCH] gnu: Add gnome-photos.
* gnu/packages/gnome.scm (gnome-photos): New variable.
---
gnu/packages/gnome.scm | 65 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 65 insertions(+)
@@ -97,6 +97,7 @@
#:use-module (gnu packages game-development)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages gimp)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
@@ -246,6 +247,70 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public gnome-photos
+ (package
+ (name "gnome-photos")
+ (version "3.34.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "12j455id5g616cn0nnj73v83aqgpavrsqszw1r5yhbpyc76lg03m"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:configure-flags
+ (list "-Dsystemduserunitdir=no"
+ "-Dtmpfilesdir=no"
+ ;; Dogtail test-suite not available.
+ "-Ddogtail=false"
+ ;; Required for RUNPATH validation.
+ (string-append "-Dc_link_args=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib/gnome-photos"))))
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("adwaita-icon-theme" ,adwaita-icon-theme)
+ ("babl" ,babl)
+ ("cairo" ,cairo)
+ ("dbus" ,dbus)
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("gegl" ,gegl)
+ ("gettext" ,gettext-minimal)
+ ("geocode-glib" ,geocode-glib)
+ ("gexiv2" ,gexiv2)
+ ("git" ,git-minimal)
+ ("glib" ,glib)
+ ("gnome-online-accounts" ,gnome-online-accounts)
+ ("gnome-online-miners" ,gnome-online-miners)
+ ("gobject-introspection" ,gobject-introspection)
+ ("grilo" ,grilo)
+ ("grilo-plugins" ,grilo-plugins)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gtk+" ,gtk+)
+ ("libdazzle" ,libdazzle)
+ ("libgdata" ,libgdata)
+ ("libgfbgraph" ,gfbgraph)
+ ("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ("librest" ,rest)
+ ("pygobject" ,python-pygobject)
+ ("tracker" ,tracker)
+ ("tracker-miners" ,tracker-miners)))
+ (synopsis "Access, organize and share your photos on GNOME desktop")
+ (description "GNOME Photos is a simple and elegant replacement for
+using a file manager to deal with photos. Enhance, crop and edit in a snap.
+Seamless cloud integration is offered through GNOME Online Accounts.")
+ (home-page "https://wiki.gnome.org/Apps/Photos")
+ (license license:gpl2)))
+
(define-public gnome-menus
(package
(name "gnome-menus")
--
2.24.1